[jira] [Commented] (GROOVY-8348) BUG! exception in phase 'semantic analysis' in source unit

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (GROOVY-8348) BUG! exception in phase 'semantic analysis' in source unit

JIRA jira@apache.org

    [ https://issues.apache.org/jira/browse/GROOVY-8348?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16197404#comment-16197404 ]

Jochen Theodorou commented on GROOVY-8348:
------------------------------------------

This means you did an improper setup for the compiler. Somewhere there is a GroovyClassLoader asked to load a script while on demand compilation is turned on and it failed. It is "semantic analysis" because it happened while trying to resolve the class InitContentMissive. This is most likely a soap UI issue.

> BUG! exception in phase 'semantic analysis' in source unit
> ----------------------------------------------------------
>
>                 Key: GROOVY-8348
>                 URL: https://issues.apache.org/jira/browse/GROOVY-8348
>             Project: Groovy
>          Issue Type: Bug
>          Components: GroovyScriptEngine
>    Affects Versions: 2.4.12
>         Environment: SOAP-UI
> Groovy
>            Reporter: Greg
>
> Hi
> I have a probleme executing an existing SOAPUI project containing groovy scripts.
> Here is the executed script
> {code:java}
> import initialize.others.*
> def initializeur=new InitContentMissive(testRunner,log,context)
> initializeur.initialize()
> {code}
> And the not explicit error message i got:
> {code:java}
> BUG! exception in phase 'semantic analysis' in source unit 'Script4.groovy' The lookup for initialize.others.InitContentMissive caused a failed compilaton. There should not have been any compilation from this call.
> {code}
> I have absolutely no idea where does it come from. Tried to browse other "semantic analysis" issues here but found no solution.
> Updated groovy-all-2.4.12.jar in ..\SoapUI-5.3.0\lib, updated java to last version.
> Thanks for your help



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)