groovy + maven

classic Classic list List threaded Threaded
52 messages Options
123456
Reply | Threaded
Open this post in threaded view
|

Re: groovy + maven

Andy Clement
Hi,

If you get these problems reported as groovy-eclipse jiras, I'll take
a look straight away.

cheers,
Andy

On 18 May 2011 15:53, Travis Schneeberger <[hidden email]> wrote:

> BTW.  Our eclipse users are reporting issues with the latest groovy eclipse
> plugin & AST transformations (ex: @ToString).  I believe they are having
> random eclipse errors or compilation errors.  Not sure if this is related.
>  I'll try to get more information tomorrow.
> ~Travis
>
> On Wed, May 18, 2011 at 5:23 PM, Andrew Eisenberg <[hidden email]>
> wrote:
>>
>> Right...I see what's going on.  The jar file wasn't created properly
>> and is missing a few classes.  I'll be able to rebuild the jar
>> tomorrow.  I'll let you know when it is available.
>>
>> On Wed, May 18, 2011 at 9:05 PM, Johann Burkard <[hidden email]>
>> wrote:
>> > -----BEGIN PGP SIGNED MESSAGE-----
>> > Hash: SHA1
>> >
>> > Hello,
>> >
>> > On 05/17/2011 10:43 PM, Andrew Eisenberg wrote:
>> >> The latest snapshot is 0.5.1-SNAPSHOT.  I'm working on getting an
>> >> official release out.
>> >
>> > I'm getting this exception with 0.5.1-SNAPSHOT:
>> >
>> > java.lang.RuntimeException: Transform
>> > groovy.grape.GrabAnnotationTransformation@14560cf cannot be run
>> >        at
>> >
>> > org.codehaus.groovy.transform.ASTTransformationVisitor$3.call(ASTTransformationVisitor.java:418)
>> >        at ...
>> > Caused by: java.lang.NoClassDefFoundError:
>> > org/codehaus/groovy/eclipse/GroovyLogManager
>> >        at
>> >
>> > org.codehaus.groovy.transform.ASTTransformationVisitor$3.call(ASTTransformationVisitor.java:404)
>> >        ... 34 more
>> > Caused by: java.lang.ClassNotFoundException:
>> > org.codehaus.groovy.eclipse.GroovyLogManager
>> >        at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
>> > ...
>> > org.codehaus.groovy.control.messages.ExceptionMessage@4ce427
>> > .../media.io/src/main/groovy/media/entities/Info.groovy: 0 General error
>> > during conversion: Transform
>> > groovy.grape.GrabAnnotationTransformation@14560cf cannot be run
>> >
>> > (Exception is repeated several time, I assume because printing the
>> > stacktrace only once could be mistaken for weakness.)
>> >
>> > Another exception:
>> >
>> > [ERROR] FATAL ERROR
>> > [INFO]
>> > -
>> > ------------------------------------------------------------------------
>> > [INFO]
>> >
>> > org.codehaus.groovy.classgen.AsmClassGenerator.access$0(Lorg/codehaus/groovy/classgen/AsmClassGenerator;)Lorg/objectweb/asm/MethodVisitor;
>> > [INFO]
>> > -
>> > ------------------------------------------------------------------------
>> > [INFO] Trace
>> > java.lang.NoSuchMethodError:
>> >
>> > org.codehaus.groovy.classgen.AsmClassGenerator.access$0(Lorg/codehaus/groovy/classgen/AsmClassGenerator;)Lorg/objectweb/asm/MethodVisitor;
>> >        at
>> >
>> > org.codehaus.groovy.classgen.AsmClassGenerator$MyMethodAdapter.<init>(AsmClassGenerator.java:4460)
>> >        at
>> >
>> > org.codehaus.groovy.classgen.AsmClassGenerator.visitConstructorOrMethod(AsmClassGenerator.java:583)
>> >        at
>> >
>> > org.codehaus.groovy.ast.ClassCodeVisitorSupport.visitConstructor(ClassCodeVisitorSupport.java:120)
>> >        at
>> >
>> > org.codehaus.groovy.classgen.AsmClassGenerator.visitConstructor(AsmClassGenerator.java:688)
>> >        at
>> > org.codehaus.groovy.ast.ClassNode.visitContents(ClassNode.java:1127)
>> >        at
>> >
>> > org.codehaus.groovy.ast.ClassCodeVisitorSupport.visitClass(ClassCodeVisitorSupport.java:51)
>> >        at
>> >
>> > org.codehaus.groovy.classgen.AsmClassGenerator.visitClass(AsmClassGenerator.java:276)
>> >        at
>> >
>> > org.codehaus.groovy.control.CompilationUnit$6.call(CompilationUnit.java:861)
>> >        at
>> >
>> > org.codehaus.groovy.control.CompilationUnit.applyToPrimaryClassNodes(CompilationUnit.java:1147)
>> >        at
>> >
>> > org.codehaus.groovy.control.CompilationUnit.doPhaseOperation(CompilationUnit.java:585)
>> >        at
>> >
>> > org.codehaus.groovy.control.CompilationUnit.processPhaseOperations(CompilationUnit.java:563)
>> >        at
>> >
>> > org.codehaus.groovy.control.CompilationUnit.compile(CompilationUnit.java:540)
>> > - --
>> > Regards,
>> >
>> > Johann Burkard
>> >
>> > <http://johannburkard.de>
>> > <http://twitter.com/johannburkard>
>> > -----BEGIN PGP SIGNATURE-----
>> > Version: GnuPG v1.4.10 (GNU/Linux)
>> > Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
>> >
>> > iEYEARECAAYFAk3UGHEACgkQgOXEH1Six2H/IACgjgr5ksfk0fIFsHO8HnpWVvRT
>> > 68cAoNzAeTbneY6Kfm7oMvLWO7KdF5hD
>> > =v+pp
>> > -----END PGP SIGNATURE-----
>> >
>> > ---------------------------------------------------------------------
>> > To unsubscribe from this list, please visit:
>> >
>> >    http://xircles.codehaus.org/manage_email
>> >
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: groovy + maven

Andrew Eisenberg
In reply to this post by Andrew Eisenberg
There is now a new snapshot version available.  I am making progress
on creating an official release.  But, things are still a bit messy.
I don't expect a non-snapshot release to be available until
Groovy-Eclipse 2.5.1 is out (end of June), but the
groovy-eclipse-compiler will be part of the release.

On Wed, May 18, 2011 at 11:23 PM, Andrew Eisenberg <[hidden email]> wrote:

> Right...I see what's going on.  The jar file wasn't created properly
> and is missing a few classes.  I'll be able to rebuild the jar
> tomorrow.  I'll let you know when it is available.
>
> On Wed, May 18, 2011 at 9:05 PM, Johann Burkard <[hidden email]> wrote:
>> -----BEGIN PGP SIGNED MESSAGE-----
>> Hash: SHA1
>>
>> Hello,
>>
>> On 05/17/2011 10:43 PM, Andrew Eisenberg wrote:
>>> The latest snapshot is 0.5.1-SNAPSHOT.  I'm working on getting an
>>> official release out.
>>
>> I'm getting this exception with 0.5.1-SNAPSHOT:
>>
>> java.lang.RuntimeException: Transform
>> groovy.grape.GrabAnnotationTransformation@14560cf cannot be run
>>        at
>> org.codehaus.groovy.transform.ASTTransformationVisitor$3.call(ASTTransformationVisitor.java:418)
>>        at ...
>> Caused by: java.lang.NoClassDefFoundError:
>> org/codehaus/groovy/eclipse/GroovyLogManager
>>        at
>> org.codehaus.groovy.transform.ASTTransformationVisitor$3.call(ASTTransformationVisitor.java:404)
>>        ... 34 more
>> Caused by: java.lang.ClassNotFoundException:
>> org.codehaus.groovy.eclipse.GroovyLogManager
>>        at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
>> ...
>> org.codehaus.groovy.control.messages.ExceptionMessage@4ce427
>> .../media.io/src/main/groovy/media/entities/Info.groovy: 0 General error
>> during conversion: Transform
>> groovy.grape.GrabAnnotationTransformation@14560cf cannot be run
>>
>> (Exception is repeated several time, I assume because printing the
>> stacktrace only once could be mistaken for weakness.)
>>
>> Another exception:
>>
>> [ERROR] FATAL ERROR
>> [INFO]
>> - ------------------------------------------------------------------------
>> [INFO]
>> org.codehaus.groovy.classgen.AsmClassGenerator.access$0(Lorg/codehaus/groovy/classgen/AsmClassGenerator;)Lorg/objectweb/asm/MethodVisitor;
>> [INFO]
>> - ------------------------------------------------------------------------
>> [INFO] Trace
>> java.lang.NoSuchMethodError:
>> org.codehaus.groovy.classgen.AsmClassGenerator.access$0(Lorg/codehaus/groovy/classgen/AsmClassGenerator;)Lorg/objectweb/asm/MethodVisitor;
>>        at
>> org.codehaus.groovy.classgen.AsmClassGenerator$MyMethodAdapter.<init>(AsmClassGenerator.java:4460)
>>        at
>> org.codehaus.groovy.classgen.AsmClassGenerator.visitConstructorOrMethod(AsmClassGenerator.java:583)
>>        at
>> org.codehaus.groovy.ast.ClassCodeVisitorSupport.visitConstructor(ClassCodeVisitorSupport.java:120)
>>        at
>> org.codehaus.groovy.classgen.AsmClassGenerator.visitConstructor(AsmClassGenerator.java:688)
>>        at org.codehaus.groovy.ast.ClassNode.visitContents(ClassNode.java:1127)
>>        at
>> org.codehaus.groovy.ast.ClassCodeVisitorSupport.visitClass(ClassCodeVisitorSupport.java:51)
>>        at
>> org.codehaus.groovy.classgen.AsmClassGenerator.visitClass(AsmClassGenerator.java:276)
>>        at
>> org.codehaus.groovy.control.CompilationUnit$6.call(CompilationUnit.java:861)
>>        at
>> org.codehaus.groovy.control.CompilationUnit.applyToPrimaryClassNodes(CompilationUnit.java:1147)
>>        at
>> org.codehaus.groovy.control.CompilationUnit.doPhaseOperation(CompilationUnit.java:585)
>>        at
>> org.codehaus.groovy.control.CompilationUnit.processPhaseOperations(CompilationUnit.java:563)
>>        at
>> org.codehaus.groovy.control.CompilationUnit.compile(CompilationUnit.java:540)
>> - --
>> Regards,
>>
>> Johann Burkard
>>
>> <http://johannburkard.de>
>> <http://twitter.com/johannburkard>
>> -----BEGIN PGP SIGNATURE-----
>> Version: GnuPG v1.4.10 (GNU/Linux)
>> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
>>
>> iEYEARECAAYFAk3UGHEACgkQgOXEH1Six2H/IACgjgr5ksfk0fIFsHO8HnpWVvRT
>> 68cAoNzAeTbneY6Kfm7oMvLWO7KdF5hD
>> =v+pp
>> -----END PGP SIGNATURE-----
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: groovy + maven

Travis Schneeberger
I just created a jira regarding the ast problems we are having with groovy-eclipse.  About half of our dev team uses eclipse and I think most have complained of this error.  I have not personally been able to reproduce the problem - go figure.

http://jira.codehaus.org/browse/GRECLIPSE-1062


On Fri, May 20, 2011 at 3:01 PM, Andrew Eisenberg <[hidden email]> wrote:
There is now a new snapshot version available.  I am making progress
on creating an official release.  But, things are still a bit messy.
I don't expect a non-snapshot release to be available until
Groovy-Eclipse 2.5.1 is out (end of June), but the
groovy-eclipse-compiler will be part of the release.

On Wed, May 18, 2011 at 11:23 PM, Andrew Eisenberg <[hidden email]> wrote:
> Right...I see what's going on.  The jar file wasn't created properly
> and is missing a few classes.  I'll be able to rebuild the jar
> tomorrow.  I'll let you know when it is available.
>
> On Wed, May 18, 2011 at 9:05 PM, Johann Burkard <[hidden email]> wrote:
>> -----BEGIN PGP SIGNED MESSAGE-----
>> Hash: SHA1
>>
>> Hello,
>>
>> On 05/17/2011 10:43 PM, Andrew Eisenberg wrote:
>>> The latest snapshot is 0.5.1-SNAPSHOT.  I'm working on getting an
>>> official release out.
>>
>> I'm getting this exception with 0.5.1-SNAPSHOT:
>>
>> java.lang.RuntimeException: Transform
>> groovy.grape.GrabAnnotationTransformation@14560cf cannot be run
>>        at
>> org.codehaus.groovy.transform.ASTTransformationVisitor$3.call(ASTTransformationVisitor.java:418)
>>        at ...
>> Caused by: java.lang.NoClassDefFoundError:
>> org/codehaus/groovy/eclipse/GroovyLogManager
>>        at
>> org.codehaus.groovy.transform.ASTTransformationVisitor$3.call(ASTTransformationVisitor.java:404)
>>        ... 34 more
>> Caused by: java.lang.ClassNotFoundException:
>> org.codehaus.groovy.eclipse.GroovyLogManager
>>        at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
>> ...
>> org.codehaus.groovy.control.messages.ExceptionMessage@4ce427
>> .../media.io/src/main/groovy/media/entities/Info.groovy: 0 General error
>> during conversion: Transform
>> groovy.grape.GrabAnnotationTransformation@14560cf cannot be run
>>
>> (Exception is repeated several time, I assume because printing the
>> stacktrace only once could be mistaken for weakness.)
>>
>> Another exception:
>>
>> [ERROR] FATAL ERROR
>> [INFO]
>> - ------------------------------------------------------------------------
>> [INFO]
>> org.codehaus.groovy.classgen.AsmClassGenerator.access$0(Lorg/codehaus/groovy/classgen/AsmClassGenerator;)Lorg/objectweb/asm/MethodVisitor;
>> [INFO]
>> - ------------------------------------------------------------------------
>> [INFO] Trace
>> java.lang.NoSuchMethodError:
>> org.codehaus.groovy.classgen.AsmClassGenerator.access$0(Lorg/codehaus/groovy/classgen/AsmClassGenerator;)Lorg/objectweb/asm/MethodVisitor;
>>        at
>> org.codehaus.groovy.classgen.AsmClassGenerator$MyMethodAdapter.<init>(AsmClassGenerator.java:4460)
>>        at
>> org.codehaus.groovy.classgen.AsmClassGenerator.visitConstructorOrMethod(AsmClassGenerator.java:583)
>>        at
>> org.codehaus.groovy.ast.ClassCodeVisitorSupport.visitConstructor(ClassCodeVisitorSupport.java:120)
>>        at
>> org.codehaus.groovy.classgen.AsmClassGenerator.visitConstructor(AsmClassGenerator.java:688)
>>        at org.codehaus.groovy.ast.ClassNode.visitContents(ClassNode.java:1127)
>>        at
>> org.codehaus.groovy.ast.ClassCodeVisitorSupport.visitClass(ClassCodeVisitorSupport.java:51)
>>        at
>> org.codehaus.groovy.classgen.AsmClassGenerator.visitClass(AsmClassGenerator.java:276)
>>        at
>> org.codehaus.groovy.control.CompilationUnit$6.call(CompilationUnit.java:861)
>>        at
>> org.codehaus.groovy.control.CompilationUnit.applyToPrimaryClassNodes(CompilationUnit.java:1147)
>>        at
>> org.codehaus.groovy.control.CompilationUnit.doPhaseOperation(CompilationUnit.java:585)
>>        at
>> org.codehaus.groovy.control.CompilationUnit.processPhaseOperations(CompilationUnit.java:563)
>>        at
>> org.codehaus.groovy.control.CompilationUnit.compile(CompilationUnit.java:540)
>> - --
>> Regards,
>>
>> Johann Burkard
>>
>> <http://johannburkard.de>
>> <http://twitter.com/johannburkard>
>> -----BEGIN PGP SIGNATURE-----
>> Version: GnuPG v1.4.10 (GNU/Linux)
>> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
>>
>> iEYEARECAAYFAk3UGHEACgkQgOXEH1Six2H/IACgjgr5ksfk0fIFsHO8HnpWVvRT
>> 68cAoNzAeTbneY6Kfm7oMvLWO7KdF5hD
>> =v+pp
>> -----END PGP SIGNATURE-----
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|

Re: groovy + maven

Johann Burkard
In reply to this post by Andrew Eisenberg
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hello,

On 05/20/2011 09:01 PM, Andrew Eisenberg wrote:
> There is now a new snapshot version available.

great. The new snapshot compiles media.io fine with 1.8.0. However, when
I run the tests, I get this error in two test cases:

Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 0.011
sec <<< FAILURE!
initializationError(com.eaio.webapp.NoAlertConfirmPromptTest)  Time
elapsed: 0.005 sec  <<< ERROR!
java.lang.NoClassDefFoundError:
org/codehaus/groovy/transform/powerassert/ValueRecorder
        at com.eaio.webapp.Pages.htmlFiles(Pages.groovy:25)

org.codehaus.groovy.transform.powerassert.ValueRecorder is not included
in groovy-1.8.0.jar but only in the 1.7 branch of Groovy (as well as in
groovy-eclipse-batch).

In Groovy 1.8.0, the class has probably been renamed to
org.codehaus.groovy.runtime.powerassert.ValueRecorder.

Is the GrEclipse compiler adding this reference to the code?
- --
Regards,

Johann Burkard

<http://johannburkard.de>
<http://twitter.com/johannburkard>
<mailto:[hidden email]>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk3X1j0ACgkQgOXEH1Six2FCGwCgzWYa/KO1ECe+qu9Mh4WSRamp
y4wAoKx9F4im5boBYmFe+buZrj+ULbwi
=V49j
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email

0x54A2C761.asc (1K) Download Attachment
0x54A2C761.asc.sig (100 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: groovy + maven

Andrew Eisenberg
Currently, we only compile using Groovy 1.7.10.  I'm working on
figuring out the best way to make this configurable.  There are a few
loose ends I need to deal with.  I should have something approaching
the final solution by the end of next week.

On Sat, May 21, 2011 at 5:11 PM, Johann Burkard <[hidden email]> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Hello,
>
> On 05/20/2011 09:01 PM, Andrew Eisenberg wrote:
>> There is now a new snapshot version available.
>
> great. The new snapshot compiles media.io fine with 1.8.0. However, when
> I run the tests, I get this error in two test cases:
>
> Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 0.011
> sec <<< FAILURE!
> initializationError(com.eaio.webapp.NoAlertConfirmPromptTest)  Time
> elapsed: 0.005 sec  <<< ERROR!
> java.lang.NoClassDefFoundError:
> org/codehaus/groovy/transform/powerassert/ValueRecorder
>        at com.eaio.webapp.Pages.htmlFiles(Pages.groovy:25)
>
> org.codehaus.groovy.transform.powerassert.ValueRecorder is not included
> in groovy-1.8.0.jar but only in the 1.7 branch of Groovy (as well as in
> groovy-eclipse-batch).
>
> In Groovy 1.8.0, the class has probably been renamed to
> org.codehaus.groovy.runtime.powerassert.ValueRecorder.
>
> Is the GrEclipse compiler adding this reference to the code?
> - --
> Regards,
>
> Johann Burkard
>
> <http://johannburkard.de>
> <http://twitter.com/johannburkard>
> <mailto:[hidden email]>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.10 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
>
> iEYEARECAAYFAk3X1j0ACgkQgOXEH1Six2FCGwCgzWYa/KO1ECe+qu9Mh4WSRamp
> y4wAoKx9F4im5boBYmFe+buZrj+ULbwi
> =V49j
> -----END PGP SIGNATURE-----
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: groovy + maven

Andrew Eisenberg
In reply to this post by Johann Burkard
Would you want to test out a new release of the
groovy-eclipse-compiler?  I changed version numbers and moved to the
codehaus repository.  We now support Groovy 1.8.  You can add this to
your pom.xml:

                       <plugin>
                               <artifactId>maven-compiler-plugin</artifactId>
                               <version>2.3.1</version>
                               <configuration>

<compilerId>groovy-eclipse-compiler</compilerId>
                               </configuration>
                               <dependencies>
                                       <dependency>

<groupId>org.codehaus.groovy</groupId>

<artifactId>groovy-eclipse-compiler</artifactId>
                                               <version>2.5.1</version>
                                       </dependency>
                                       <dependency>

<groupId>org.codehaus.groovy</groupId>

<artifactId>groovy-eclipse-batch</artifactId>
                                               <version>1.7.10-01</version>
                                       </dependency>
                               </dependencies>
                       </plugin>

and this (to ensure you pick up the right repository):
       <pluginRepositories>
               <pluginRepository>
                       <id>codehau.org</id>
                       <url>http://repository.codehaus.org</url>
               </pluginRepository>
       </pluginRepositories>

If you want to use 1.8.0, then just remove the 1.7.10-01 dependency.
That is the default.  Please let me know if this works for you.  Thanks.

--a

On Sat, May 21, 2011 at 5:11 PM, Johann Burkard <[hidden email]> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Hello,
>
> On 05/20/2011 09:01 PM, Andrew Eisenberg wrote:
>> There is now a new snapshot version available.
>
> great. The new snapshot compiles media.io fine with 1.8.0. However, when
> I run the tests, I get this error in two test cases:
>
> Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 0.011
> sec <<< FAILURE!
> initializationError(com.eaio.webapp.NoAlertConfirmPromptTest)  Time
> elapsed: 0.005 sec  <<< ERROR!
> java.lang.NoClassDefFoundError:
> org/codehaus/groovy/transform/powerassert/ValueRecorder
>        at com.eaio.webapp.Pages.htmlFiles(Pages.groovy:25)
>
> org.codehaus.groovy.transform.powerassert.ValueRecorder is not included
> in groovy-1.8.0.jar but only in the 1.7 branch of Groovy (as well as in
> groovy-eclipse-batch).
>
> In Groovy 1.8.0, the class has probably been renamed to
> org.codehaus.groovy.runtime.powerassert.ValueRecorder.
>
> Is the GrEclipse compiler adding this reference to the code?
> - --
> Regards,
>
> Johann Burkard
>
> <http://johannburkard.de>
> <http://twitter.com/johannburkard>
> <mailto:[hidden email]>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.10 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
>
> iEYEARECAAYFAk3X1j0ACgkQgOXEH1Six2FCGwCgzWYa/KO1ECe+qu9Mh4WSRamp
> y4wAoKx9F4im5boBYmFe+buZrj+ULbwi
> =V49j
> -----END PGP SIGNATURE-----
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: groovy + maven

Johann Burkard
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Andrew,

On 05/25/2011 12:20 AM, Andrew Eisenberg wrote:
> Would you want to test out a new release of the
> groovy-eclipse-compiler?

of course. With this configuration:

<plugin>
<artifactId>maven-compiler-plugin</artifactId>
<version>2.3.1</version>
<configuration>
<compilerId>groovy-eclipse-compiler</compilerId>
</configuration>
<dependencies>
<dependency>
<groupId>org.codehaus.groovy</groupId>
<artifactId>groovy-eclipse-compiler</artifactId>
<version>2.5.1</version>
</dependency>
<dependency>
<groupId>org.codehaus.groovy</groupId>
<artifactId>groovy</artifactId>
<version>1.8.0</version>
</dependency>
</dependencies>
</plugin>

<plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>build-helper-maven-plugin</artifactId>
<version>1.5</version>
<executions>
<execution>
<id>add-source</id>
<phase>generate-sources</phase>
<goals>
<goal>add-source</goal>
</goals>
<configuration>
<sources>
<source>src/main/groovy</source>
</sources>
</configuration>
</execution>
<execution>
<id>add-test-source</id>
<phase>generate-test-sources</phase>
<goals>
<goal>add-test-source</goal>
</goals>
<configuration>
<sources>
<source>src/test/groovy</source>
</sources>
</configuration>
</execution>
</executions>
</plugin>

<pluginRepositories>
<pluginRepository>
<id>codehaus.org</id>
<url>http://repository.codehaus.org</url>
</pluginRepository>
</pluginRepositories>

I get this exception when compiling:

java.lang.NoSuchMethodError:
org.codehaus.groovy.classgen.InnerClassCompletionVisitor.<init>(Lorg/codehaus/groovy/control/CompilationUnit;Lorg/codehaus/groovy/control/SourceUnit;)V
        at
org.codehaus.groovy.control.CompilationUnit$11.call(CompilationUnit.java:213)
- --
Regards,

Johann Burkard

<http://johannburkard.de>
<http://twitter.com/johannburkard>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk3c3o0ACgkQgOXEH1Six2FhrQCbB87h7P+rm+l887nhYm3pLKjf
p6YAoIvt38dFjAZK5d2JPYiEEvk/R+ch
=z8Rg
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email

0x54A2C761.asc (1K) Download Attachment
0x54A2C761.asc.sig (100 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: groovy + maven

Andrew Eisenberg
Thanks for getting back to me on this.  I only have a very simple
project that I compile against, so it is not testing all paths in the
compiler.  I'll have a deeper look.  I'll also look for a larger
project to compile (do you know of any?).

On Wed, May 25, 2011 at 12:48 PM, Johann Burkard
<[hidden email]> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Andrew,
>
> On 05/25/2011 12:20 AM, Andrew Eisenberg wrote:
>> Would you want to test out a new release of the
>> groovy-eclipse-compiler?
>
> of course. With this configuration:
>
> <plugin>
> <artifactId>maven-compiler-plugin</artifactId>
> <version>2.3.1</version>
> <configuration>
> <compilerId>groovy-eclipse-compiler</compilerId>
> </configuration>
> <dependencies>
> <dependency>
> <groupId>org.codehaus.groovy</groupId>
> <artifactId>groovy-eclipse-compiler</artifactId>
> <version>2.5.1</version>
> </dependency>
> <dependency>
> <groupId>org.codehaus.groovy</groupId>
> <artifactId>groovy</artifactId>
> <version>1.8.0</version>
> </dependency>
> </dependencies>
> </plugin>
>
> <plugin>
> <groupId>org.codehaus.mojo</groupId>
> <artifactId>build-helper-maven-plugin</artifactId>
> <version>1.5</version>
> <executions>
> <execution>
> <id>add-source</id>
> <phase>generate-sources</phase>
> <goals>
> <goal>add-source</goal>
> </goals>
> <configuration>
> <sources>
> <source>src/main/groovy</source>
> </sources>
> </configuration>
> </execution>
> <execution>
> <id>add-test-source</id>
> <phase>generate-test-sources</phase>
> <goals>
> <goal>add-test-source</goal>
> </goals>
> <configuration>
> <sources>
> <source>src/test/groovy</source>
> </sources>
> </configuration>
> </execution>
> </executions>
> </plugin>
>
> <pluginRepositories>
> <pluginRepository>
> <id>codehaus.org</id>
> <url>http://repository.codehaus.org</url>
> </pluginRepository>
> </pluginRepositories>
>
> I get this exception when compiling:
>
> java.lang.NoSuchMethodError:
> org.codehaus.groovy.classgen.InnerClassCompletionVisitor.<init>(Lorg/codehaus/groovy/control/CompilationUnit;Lorg/codehaus/groovy/control/SourceUnit;)V
>        at
> org.codehaus.groovy.control.CompilationUnit$11.call(CompilationUnit.java:213)
> - --
> Regards,
>
> Johann Burkard
>
> <http://johannburkard.de>
> <http://twitter.com/johannburkard>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.10 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
>
> iEYEARECAAYFAk3c3o0ACgkQgOXEH1Six2FhrQCbB87h7P+rm+l887nhYm3pLKjf
> p6YAoIvt38dFjAZK5d2JPYiEEvk/R+ch
> =z8Rg
> -----END PGP SIGNATURE-----
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: groovy + maven

Travis Schneeberger
I've tried out the new eclipse compiler and got the following:


[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile (default-compile)
on project rice-core-framework: Execution default-compile of goal org.apache.maven.plugins:maven-compiler-plug
in:2.3.2:compile failed: A required class was missing while executing org.apache.maven.plugins:maven-compiler-
plugin:2.3.2:compile: org/codehaus/groovy/ast/ClassCodeExpressionTransformer
[ERROR] -----------------------------------------------------
[ERROR] realm =    plugin>org.apache.maven.plugins:maven-compiler-plugin:2.3.2
[ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy
[ERROR] urls[0] = file:/c:/m2repo/org/apache/maven/plugins/maven-compiler-plugin/2.3.2/maven-compiler-plugin-2
.3.2.jar
[ERROR] urls[1] = file:/c:/m2repo/org/codehaus/groovy/groovy-eclipse-compiler/2.5.1/groovy-eclipse-compiler-2.
5.1.jar
[ERROR] urls[2] = file:/c:/m2repo/org/codehaus/groovy/groovy-eclipse-batch/1.7.10-SNAPSHOT/groovy-eclipse-batc
h-1.7.10-SNAPSHOT.jar
[ERROR] urls[3] = file:/c:/m2repo/org/apache/xbean/xbean-reflect/3.4/xbean-reflect-3.4.jar
[ERROR] urls[4] = file:/c:/m2repo/log4j/log4j/1.2.12/log4j-1.2.12.jar
[ERROR] urls[5] = file:/c:/m2repo/commons-logging/commons-logging-api/1.1/commons-logging-api-1.1.jar
[ERROR] urls[6] = file:/c:/m2repo/com/google/collections/google-collections/1.0/google-collections-1.0.jar
[ERROR] urls[7] = file:/c:/m2repo/junit/junit/3.8.2/junit-3.8.2.jar
[ERROR] urls[8] = file:/c:/m2repo/org/codehaus/plexus/plexus-utils/2.0.5/plexus-utils-2.0.5.jar
[ERROR] urls[9] = file:/c:/m2repo/org/codehaus/plexus/plexus-compiler-api/1.8.1/plexus-compiler-api-1.8.1.jar
[ERROR] urls[10] = file:/c:/m2repo/org/codehaus/plexus/plexus-compiler-manager/1.8.1/plexus-compiler-manager-1
.8.1.jar
[ERROR] urls[11] = file:/c:/m2repo/org/codehaus/plexus/plexus-compiler-javac/1.8.1/plexus-compiler-javac-1.8.1
.jar
[ERROR] Number of foreign imports: 1
[ERROR] import: Entry[import  from realm ClassRealm[project>org.kuali.rice:rice:2.0.0-m5-SNAPSHOT, parent: Cla
ssRealm[maven.api, parent: null]]]
[ERROR]
[ERROR] -----------------------------------------------------: org.codehaus.groovy.ast.ClassCodeExpressionTran
sformer

I realized that this missing class is in the groovy-all jar so I added that as a dependency of the compiler and got the following:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile (default-compile)
on project rice-core-framework: Execution default-compile of goal org.apache.maven.plugins:maven-compiler-plug
in:2.3.2:compile failed: An API incompatibility was encountered while executing org.apache.maven.plugins:maven
-compiler-plugin:2.3.2:compile: java.lang.VerifyError: (class: org/codehaus/groovy/antlr/parser/GroovyLexer, m
ethod: makeToken signature: (I)Lantlr/Token;) Wrong return type in function
[ERROR] -----------------------------------------------------
[ERROR] realm =    plugin>org.apache.maven.plugins:maven-compiler-plugin:2.3.2
[ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy
[ERROR] urls[0] = file:/c:/m2repo/org/apache/maven/plugins/maven-compiler-plugin/2.3.2/maven-compiler-plugin-2
.3.2.jar
[ERROR] urls[1] = file:/c:/m2repo/org/codehaus/groovy/groovy-eclipse-compiler/2.5.1/groovy-eclipse-compiler-2.
5.1.jar
[ERROR] urls[2] = file:/c:/m2repo/org/codehaus/groovy/groovy-eclipse-batch/1.7.10-SNAPSHOT/groovy-eclipse-batc
h-1.7.10-SNAPSHOT.jar
[ERROR] urls[3] = file:/c:/m2repo/org/apache/xbean/xbean-reflect/3.4/xbean-reflect-3.4.jar
[ERROR] urls[4] = file:/c:/m2repo/log4j/log4j/1.2.12/log4j-1.2.12.jar
[ERROR] urls[5] = file:/c:/m2repo/commons-logging/commons-logging-api/1.1/commons-logging-api-1.1.jar
[ERROR] urls[6] = file:/c:/m2repo/com/google/collections/google-collections/1.0/google-collections-1.0.jar
[ERROR] urls[7] = file:/c:/m2repo/junit/junit/3.8.2/junit-3.8.2.jar
[ERROR] urls[8] = file:/c:/m2repo/org/codehaus/groovy/groovy-all/1.8.0/groovy-all-1.8.0.jar
[ERROR] urls[9] = file:/c:/m2repo/org/codehaus/plexus/plexus-utils/2.0.5/plexus-utils-2.0.5.jar
[ERROR] urls[10] = file:/c:/m2repo/org/codehaus/plexus/plexus-compiler-api/1.8.1/plexus-compiler-api-1.8.1.jar

[ERROR] urls[11] = file:/c:/m2repo/org/codehaus/plexus/plexus-compiler-manager/1.8.1/plexus-compiler-manager-1
.8.1.jar
[ERROR] urls[12] = file:/c:/m2repo/org/codehaus/plexus/plexus-compiler-javac/1.8.1/plexus-compiler-javac-1.8.1
.jar
[ERROR] Number of foreign imports: 1
[ERROR] import: Entry[import  from realm ClassRealm[project>org.kuali.rice:rice:2.0.0-m5-SNAPSHOT, parent: Cla
ssRealm[maven.api, parent: null]]]
[ERROR]

Any ideas?

~Travis

On Wed, May 25, 2011 at 11:56 AM, Andrew Eisenberg <[hidden email]> wrote:
Thanks for getting back to me on this.  I only have a very simple
project that I compile against, so it is not testing all paths in the
compiler.  I'll have a deeper look.  I'll also look for a larger
project to compile (do you know of any?).

On Wed, May 25, 2011 at 12:48 PM, Johann Burkard
<[hidden email]> wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Andrew,
>
> On 05/25/2011 12:20 AM, Andrew Eisenberg wrote:
>> Would you want to test out a new release of the
>> groovy-eclipse-compiler?
>
> of course. With this configuration:
>
> <plugin>
> <artifactId>maven-compiler-plugin</artifactId>
> <version>2.3.1</version>
> <configuration>
> <compilerId>groovy-eclipse-compiler</compilerId>
> </configuration>
> <dependencies>
> <dependency>
> <groupId>org.codehaus.groovy</groupId>
> <artifactId>groovy-eclipse-compiler</artifactId>
> <version>2.5.1</version>
> </dependency>
> <dependency>
> <groupId>org.codehaus.groovy</groupId>
> <artifactId>groovy</artifactId>
> <version>1.8.0</version>
> </dependency>
> </dependencies>
> </plugin>
>
> <plugin>
> <groupId>org.codehaus.mojo</groupId>
> <artifactId>build-helper-maven-plugin</artifactId>
> <version>1.5</version>
> <executions>
> <execution>
> <id>add-source</id>
> <phase>generate-sources</phase>
> <goals>
> <goal>add-source</goal>
> </goals>
> <configuration>
> <sources>
> <source>src/main/groovy</source>
> </sources>
> </configuration>
> </execution>
> <execution>
> <id>add-test-source</id>
> <phase>generate-test-sources</phase>
> <goals>
> <goal>add-test-source</goal>
> </goals>
> <configuration>
> <sources>
> <source>src/test/groovy</source>
> </sources>
> </configuration>
> </execution>
> </executions>
> </plugin>
>
> <pluginRepositories>
> <pluginRepository>
> <id>codehaus.org</id>
> <url>http://repository.codehaus.org</url>
> </pluginRepository>
> </pluginRepositories>
>
> I get this exception when compiling:
>
> java.lang.NoSuchMethodError:
> org.codehaus.groovy.classgen.InnerClassCompletionVisitor.<init>(Lorg/codehaus/groovy/control/CompilationUnit;Lorg/codehaus/groovy/control/SourceUnit;)V
>        at
> org.codehaus.groovy.control.CompilationUnit$11.call(CompilationUnit.java:213)
> - --
> Regards,
>
> Johann Burkard
>
> <http://johannburkard.de>
> <http://twitter.com/johannburkard>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.10 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
>
> iEYEARECAAYFAk3c3o0ACgkQgOXEH1Six2FhrQCbB87h7P+rm+l887nhYm3pLKjf
> p6YAoIvt38dFjAZK5d2JPYiEEvk/R+ch
> =z8Rg
> -----END PGP SIGNATURE-----
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|

Re: groovy + maven

Andrew Eisenberg
Thanks for trying this.  It looks like the problem you are having is
that you are picking up the snapshot version of the 1.7.10
groovy-eclipse-batch artifact.  That one does have a problem.  I'm not
sure if this is something coming from your pom, or if this a problem
in my area.  Can you send over the relevant pom snippet where you
declare a dependency on groovy-eclipse-compiler?

The problem that Johann is having is different.  It looks like some
groovy 1.7 files ended up in the groovy 1.8 artifact.  It is a
packaging problem.

Anyone have a good-sized groovy-maven project I can play with?



On Wed, May 25, 2011 at 12:47 PM, Travis Schneeberger
<[hidden email]> wrote:

> I've tried out the new eclipse compiler and got the following:
>
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile
> (default-compile)
> on project rice-core-framework: Execution default-compile of goal
> org.apache.maven.plugins:maven-compiler-plug
> in:2.3.2:compile failed: A required class was missing while executing
> org.apache.maven.plugins:maven-compiler-
> plugin:2.3.2:compile: org/codehaus/groovy/ast/ClassCodeExpressionTransformer
> [ERROR] -----------------------------------------------------
> [ERROR] realm =
>  plugin>org.apache.maven.plugins:maven-compiler-plugin:2.3.2
> [ERROR] strategy =
> org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy
> [ERROR] urls[0] =
> file:/c:/m2repo/org/apache/maven/plugins/maven-compiler-plugin/2.3.2/maven-compiler-plugin-2
> .3.2.jar
> [ERROR] urls[1] =
> file:/c:/m2repo/org/codehaus/groovy/groovy-eclipse-compiler/2.5.1/groovy-eclipse-compiler-2.
> 5.1.jar
> [ERROR] urls[2] =
> file:/c:/m2repo/org/codehaus/groovy/groovy-eclipse-batch/1.7.10-SNAPSHOT/groovy-eclipse-batc
> h-1.7.10-SNAPSHOT.jar
> [ERROR] urls[3] =
> file:/c:/m2repo/org/apache/xbean/xbean-reflect/3.4/xbean-reflect-3.4.jar
> [ERROR] urls[4] = file:/c:/m2repo/log4j/log4j/1.2.12/log4j-1.2.12.jar
> [ERROR] urls[5] =
> file:/c:/m2repo/commons-logging/commons-logging-api/1.1/commons-logging-api-1.1.jar
> [ERROR] urls[6] =
> file:/c:/m2repo/com/google/collections/google-collections/1.0/google-collections-1.0.jar
> [ERROR] urls[7] = file:/c:/m2repo/junit/junit/3.8.2/junit-3.8.2.jar
> [ERROR] urls[8] =
> file:/c:/m2repo/org/codehaus/plexus/plexus-utils/2.0.5/plexus-utils-2.0.5.jar
> [ERROR] urls[9] =
> file:/c:/m2repo/org/codehaus/plexus/plexus-compiler-api/1.8.1/plexus-compiler-api-1.8.1.jar
> [ERROR] urls[10] =
> file:/c:/m2repo/org/codehaus/plexus/plexus-compiler-manager/1.8.1/plexus-compiler-manager-1
> .8.1.jar
> [ERROR] urls[11] =
> file:/c:/m2repo/org/codehaus/plexus/plexus-compiler-javac/1.8.1/plexus-compiler-javac-1.8.1
> .jar
> [ERROR] Number of foreign imports: 1
> [ERROR] import: Entry[import  from realm
> ClassRealm[project>org.kuali.rice:rice:2.0.0-m5-SNAPSHOT, parent: Cla
> ssRealm[maven.api, parent: null]]]
> [ERROR]
> [ERROR] -----------------------------------------------------:
> org.codehaus.groovy.ast.ClassCodeExpressionTran
> sformer
> I realized that this missing class is in the groovy-all jar so I added that
> as a dependency of the compiler and got the following:
>
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile
> (default-compile)
> on project rice-core-framework: Execution default-compile of goal
> org.apache.maven.plugins:maven-compiler-plug
> in:2.3.2:compile failed: An API incompatibility was encountered while
> executing org.apache.maven.plugins:maven
> -compiler-plugin:2.3.2:compile: java.lang.VerifyError: (class:
> org/codehaus/groovy/antlr/parser/GroovyLexer, m
> ethod: makeToken signature: (I)Lantlr/Token;) Wrong return type in function
> [ERROR] -----------------------------------------------------
> [ERROR] realm =
>  plugin>org.apache.maven.plugins:maven-compiler-plugin:2.3.2
> [ERROR] strategy =
> org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy
> [ERROR] urls[0] =
> file:/c:/m2repo/org/apache/maven/plugins/maven-compiler-plugin/2.3.2/maven-compiler-plugin-2
> .3.2.jar
> [ERROR] urls[1] =
> file:/c:/m2repo/org/codehaus/groovy/groovy-eclipse-compiler/2.5.1/groovy-eclipse-compiler-2.
> 5.1.jar
> [ERROR] urls[2] =
> file:/c:/m2repo/org/codehaus/groovy/groovy-eclipse-batch/1.7.10-SNAPSHOT/groovy-eclipse-batc
> h-1.7.10-SNAPSHOT.jar
> [ERROR] urls[3] =
> file:/c:/m2repo/org/apache/xbean/xbean-reflect/3.4/xbean-reflect-3.4.jar
> [ERROR] urls[4] = file:/c:/m2repo/log4j/log4j/1.2.12/log4j-1.2.12.jar
> [ERROR] urls[5] =
> file:/c:/m2repo/commons-logging/commons-logging-api/1.1/commons-logging-api-1.1.jar
> [ERROR] urls[6] =
> file:/c:/m2repo/com/google/collections/google-collections/1.0/google-collections-1.0.jar
> [ERROR] urls[7] = file:/c:/m2repo/junit/junit/3.8.2/junit-3.8.2.jar
> [ERROR] urls[8] =
> file:/c:/m2repo/org/codehaus/groovy/groovy-all/1.8.0/groovy-all-1.8.0.jar
> [ERROR] urls[9] =
> file:/c:/m2repo/org/codehaus/plexus/plexus-utils/2.0.5/plexus-utils-2.0.5.jar
> [ERROR] urls[10] =
> file:/c:/m2repo/org/codehaus/plexus/plexus-compiler-api/1.8.1/plexus-compiler-api-1.8.1.jar
> [ERROR] urls[11] =
> file:/c:/m2repo/org/codehaus/plexus/plexus-compiler-manager/1.8.1/plexus-compiler-manager-1
> .8.1.jar
> [ERROR] urls[12] =
> file:/c:/m2repo/org/codehaus/plexus/plexus-compiler-javac/1.8.1/plexus-compiler-javac-1.8.1
> .jar
> [ERROR] Number of foreign imports: 1
> [ERROR] import: Entry[import  from realm
> ClassRealm[project>org.kuali.rice:rice:2.0.0-m5-SNAPSHOT, parent: Cla
> ssRealm[maven.api, parent: null]]]
> [ERROR]
>
> Any ideas?
>
> ~Travis
> On Wed, May 25, 2011 at 11:56 AM, Andrew Eisenberg <[hidden email]>
> wrote:
>>
>> Thanks for getting back to me on this.  I only have a very simple
>> project that I compile against, so it is not testing all paths in the
>> compiler.  I'll have a deeper look.  I'll also look for a larger
>> project to compile (do you know of any?).
>>
>> On Wed, May 25, 2011 at 12:48 PM, Johann Burkard
>> <[hidden email]> wrote:
>> > -----BEGIN PGP SIGNED MESSAGE-----
>> > Hash: SHA1
>> >
>> > Andrew,
>> >
>> > On 05/25/2011 12:20 AM, Andrew Eisenberg wrote:
>> >> Would you want to test out a new release of the
>> >> groovy-eclipse-compiler?
>> >
>> > of course. With this configuration:
>> >
>> > <plugin>
>> > <artifactId>maven-compiler-plugin</artifactId>
>> > <version>2.3.1</version>
>> > <configuration>
>> > <compilerId>groovy-eclipse-compiler</compilerId>
>> > </configuration>
>> > <dependencies>
>> > <dependency>
>> > <groupId>org.codehaus.groovy</groupId>
>> > <artifactId>groovy-eclipse-compiler</artifactId>
>> > <version>2.5.1</version>
>> > </dependency>
>> > <dependency>
>> > <groupId>org.codehaus.groovy</groupId>
>> > <artifactId>groovy</artifactId>
>> > <version>1.8.0</version>
>> > </dependency>
>> > </dependencies>
>> > </plugin>
>> >
>> > <plugin>
>> > <groupId>org.codehaus.mojo</groupId>
>> > <artifactId>build-helper-maven-plugin</artifactId>
>> > <version>1.5</version>
>> > <executions>
>> > <execution>
>> > <id>add-source</id>
>> > <phase>generate-sources</phase>
>> > <goals>
>> > <goal>add-source</goal>
>> > </goals>
>> > <configuration>
>> > <sources>
>> > <source>src/main/groovy</source>
>> > </sources>
>> > </configuration>
>> > </execution>
>> > <execution>
>> > <id>add-test-source</id>
>> > <phase>generate-test-sources</phase>
>> > <goals>
>> > <goal>add-test-source</goal>
>> > </goals>
>> > <configuration>
>> > <sources>
>> > <source>src/test/groovy</source>
>> > </sources>
>> > </configuration>
>> > </execution>
>> > </executions>
>> > </plugin>
>> >
>> > <pluginRepositories>
>> > <pluginRepository>
>> > <id>codehaus.org</id>
>> > <url>http://repository.codehaus.org</url>
>> > </pluginRepository>
>> > </pluginRepositories>
>> >
>> > I get this exception when compiling:
>> >
>> > java.lang.NoSuchMethodError:
>> >
>> > org.codehaus.groovy.classgen.InnerClassCompletionVisitor.<init>(Lorg/codehaus/groovy/control/CompilationUnit;Lorg/codehaus/groovy/control/SourceUnit;)V
>> >        at
>> >
>> > org.codehaus.groovy.control.CompilationUnit$11.call(CompilationUnit.java:213)
>> > - --
>> > Regards,
>> >
>> > Johann Burkard
>> >
>> > <http://johannburkard.de>
>> > <http://twitter.com/johannburkard>
>> > -----BEGIN PGP SIGNATURE-----
>> > Version: GnuPG v1.4.10 (GNU/Linux)
>> > Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
>> >
>> > iEYEARECAAYFAk3c3o0ACgkQgOXEH1Six2FhrQCbB87h7P+rm+l887nhYm3pLKjf
>> > p6YAoIvt38dFjAZK5d2JPYiEEvk/R+ch
>> > =z8Rg
>> > -----END PGP SIGNATURE-----
>> >
>> > ---------------------------------------------------------------------
>> > To unsubscribe from this list, please visit:
>> >
>> >    http://xircles.codehaus.org/manage_email
>> >
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


123456