groovy git commit: support detecting JDK9+ in vmplugin (build tweak for JDK7)

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

groovy git commit: support detecting JDK9+ in vmplugin (build tweak for JDK7)

paulk
Repository: groovy
Updated Branches:
  refs/heads/GROOVY_2_5_X 7ad8f3884 -> a7df83701


support detecting JDK9+ in vmplugin (build tweak for JDK7)


Project: http://git-wip-us.apache.org/repos/asf/groovy/repo
Commit: http://git-wip-us.apache.org/repos/asf/groovy/commit/a7df8370
Tree: http://git-wip-us.apache.org/repos/asf/groovy/tree/a7df8370
Diff: http://git-wip-us.apache.org/repos/asf/groovy/diff/a7df8370

Branch: refs/heads/GROOVY_2_5_X
Commit: a7df83701f73845d3e4e9ebc3742b9c99a820d7f
Parents: 7ad8f38
Author: Paul King <[hidden email]>
Authored: Thu Aug 9 00:47:47 2018 +1000
Committer: Paul King <[hidden email]>
Committed: Thu Aug 9 00:47:47 2018 +1000

----------------------------------------------------------------------
 build.gradle | 2 ++
 1 file changed, 2 insertions(+)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/groovy/blob/a7df8370/build.gradle
----------------------------------------------------------------------
diff --git a/build.gradle b/build.gradle
index f709cd3..81fa73f 100644
--- a/build.gradle
+++ b/build.gradle
@@ -259,6 +259,7 @@ sourceSets {
             if (!JavaVersion.current().isJava8Compatible()) {
                 exclude '**/v8/*'
                 exclude '**/vm8/*'
+                exclude '**/v9/*'
             }
         }
         groovy {
@@ -266,6 +267,7 @@ sourceSets {
             if (!JavaVersion.current().isJava8Compatible()) {
                 exclude '**/v8/*'
                 exclude '**/vm8/*'
+                exclude '**/v9/*'
             }
         }
         resources {