[groovy] branch GROOVY_3_0_X updated (e84359e -> 8950dc1)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[groovy] branch GROOVY_3_0_X updated (e84359e -> 8950dc1)

paulk
This is an automated email from the ASF dual-hosted git repository.

paulk pushed a change to branch GROOVY_3_0_X
in repository https://gitbox.apache.org/repos/asf/groovy.git.


    from e84359e  ConversionHandler: Remove unnecessary null check for value of final field which is always initialized.
     new 57f0ef4  GROOVY-9474: Upgrade spock to latest version (adjust gradle build for groovy-nio)
     new 8950dc1  GROOVY-9474: Upgrade spock to latest version (adjust gradle build for groovy-templates)

The 2 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "add" were already present in the repository and have only
been added to this reference.


Summary of changes:
 build.gradle                                | 2 ++
 subprojects/groovy-nio/build.gradle         | 5 +++++
 subprojects/groovy-templates/build.gradle   | 7 +++++++
 subprojects/groovy-test-junit5/build.gradle | 5 -----
 4 files changed, 14 insertions(+), 5 deletions(-)

Reply | Threaded
Open this post in threaded view
|

[groovy] 01/02: GROOVY-9474: Upgrade spock to latest version (adjust gradle build for groovy-nio)

paulk
This is an automated email from the ASF dual-hosted git repository.

paulk pushed a commit to branch GROOVY_3_0_X
in repository https://gitbox.apache.org/repos/asf/groovy.git

commit 57f0ef4c784e1b756e558bd9467278cd592b98eb
Author: Paul King <[hidden email]>
AuthorDate: Sun Mar 22 17:38:53 2020 +1000

    GROOVY-9474: Upgrade spock to latest version (adjust gradle build for groovy-nio)
---
 build.gradle                                | 2 ++
 subprojects/groovy-nio/build.gradle         | 5 +++++
 subprojects/groovy-test-junit5/build.gradle | 5 -----
 3 files changed, 7 insertions(+), 5 deletions(-)

diff --git a/build.gradle b/build.gradle
index b209351..9bf839d 100644
--- a/build.gradle
+++ b/build.gradle
@@ -154,6 +154,8 @@ ext {
     spotbugsVersion = '4.0.1'
     spotbugsAnnotationsVersion = '4.0.1'
     checkstyleVersion = '8.30'
+    junit5Version = '5.6.0'
+    junit5PlatformVersion = '1.6.0'
 }
 
 dependencies {
diff --git a/subprojects/groovy-nio/build.gradle b/subprojects/groovy-nio/build.gradle
index ae58a2e..afb4812 100644
--- a/subprojects/groovy-nio/build.gradle
+++ b/subprojects/groovy-nio/build.gradle
@@ -28,10 +28,15 @@ dependencies {
     testImplementation ("org.spockframework:spock-core:$spockVersion") {
         exclude group: 'org.codehaus.groovy'
     }
+    testImplementation ("org.spockframework:spock-junit4:$spockVersion")
 }
 
 task moduleDescriptor(type: org.codehaus.groovy.gradle.WriteExtensionDescriptorTask) {
     extensionClasses = 'org.apache.groovy.nio.extensions.NioExtensions'
 }
 
+test {
+    useJUnitPlatform()
+}
+
 compileJava.dependsOn moduleDescriptor
diff --git a/subprojects/groovy-test-junit5/build.gradle b/subprojects/groovy-test-junit5/build.gradle
index 050d13a..ea3a530 100644
--- a/subprojects/groovy-test-junit5/build.gradle
+++ b/subprojects/groovy-test-junit5/build.gradle
@@ -17,11 +17,6 @@
  *  under the License.
  */
 
-ext {
-    junit5Version = '5.6.0'
-    junit5PlatformVersion = '1.6.0'
-}
-
 dependencies {
     api rootProject // JUnit5Runner implements GroovyRunner...
     implementation("org.junit.platform:junit-platform-launcher:$junit5PlatformVersion") {

Reply | Threaded
Open this post in threaded view
|

[groovy] 02/02: GROOVY-9474: Upgrade spock to latest version (adjust gradle build for groovy-templates)

paulk
In reply to this post by paulk
This is an automated email from the ASF dual-hosted git repository.

paulk pushed a commit to branch GROOVY_3_0_X
in repository https://gitbox.apache.org/repos/asf/groovy.git

commit 8950dc15df4b0dde142fc02fbf03487620c00696
Author: Paul King <[hidden email]>
AuthorDate: Sun Mar 22 21:19:46 2020 +1000

    GROOVY-9474: Upgrade spock to latest version (adjust gradle build for groovy-templates)
---
 subprojects/groovy-templates/build.gradle | 7 +++++++
 1 file changed, 7 insertions(+)

diff --git a/subprojects/groovy-templates/build.gradle b/subprojects/groovy-templates/build.gradle
index 3b7374b..45bd316 100644
--- a/subprojects/groovy-templates/build.gradle
+++ b/subprojects/groovy-templates/build.gradle
@@ -30,6 +30,13 @@ dependencies {
     testImplementation("org.spockframework:spock-core:$spockVersion") {
         exclude group: 'org.codehaus.groovy'
     }
+    testRuntimeOnly("org.junit.vintage:junit-vintage-engine:$junit5Version") {
+        because 'for JUnit 3/4 tests as well as JUnit 5'
+    }
+}
+
+test {
+    useJUnitPlatform()
 }
 
 task backportJar(type:Jar) {