[VOTE] Release Apache Groovy 2.5.3

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[VOTE] Release Apache Groovy 2.5.3

paulk_asert

Dear development community,

I am happy to start the VOTE thread for a Groovy 2.5.3 release!

This release includes 46 bug fixes/improvements as outlined in the changelog:

Tag commit id: a05a9371f51112cb20f967d6ee204ea20bec2701

The artifacts to be voted on are located as follows (r29887).

Release artifacts are signed with a key from the following file:

Please vote on releasing this package as Apache Groovy 2.5.3.

Reminder on ASF release approval requirements for PMC members:
Hints on validating checksums/signatures (but replace md5sum with sha256sum):

The vote is open for the next 72 hours and passes if a majority of at least three +1 PMC votes are cast.

[ ] +1 Release Apache Groovy 2.5.3
[ ]  0 I don't have a strong opinion about this, but I assume it's ok
[ ] -1 Do not release Apache Groovy 2.5.3 because...

Here is my vote:

+1 (binding)

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Groovy 2.5.3

Guillaume Laforge
Administrator
+1 (binding)

Built from source successfully.
Ran some console related smoke tests, and all went fine.

Guillaume


On Fri, Oct 5, 2018 at 8:17 AM Paul King <[hidden email]> wrote:

Dear development community,

I am happy to start the VOTE thread for a Groovy 2.5.3 release!

This release includes 46 bug fixes/improvements as outlined in the changelog:

Tag commit id: a05a9371f51112cb20f967d6ee204ea20bec2701

The artifacts to be voted on are located as follows (r29887).

Release artifacts are signed with a key from the following file:

Please vote on releasing this package as Apache Groovy 2.5.3.

Reminder on ASF release approval requirements for PMC members:
Hints on validating checksums/signatures (but replace md5sum with sha256sum):

The vote is open for the next 72 hours and passes if a majority of at least three +1 PMC votes are cast.

[ ] +1 Release Apache Groovy 2.5.3
[ ]  0 I don't have a strong opinion about this, but I assume it's ok
[ ] -1 Do not release Apache Groovy 2.5.3 because...

Here is my vote:

+1 (binding)



--
Guillaume Laforge
Apache Groovy committer & PMC Vice-President
Developer Advocate @ Google Cloud Platform

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Groovy 2.5.3

Andres Almiray
+1 (binding)

Built from source successfully.

-------------------------------------------
Java Champion; Groovy Enthusiast
JCP EC Associate Seat
http://andresalmiray.com
http://www.linkedin.com/in/aalmiray
--
What goes up, must come down. Ask any system administrator.
There are 10 types of people in the world: Those who understand binary, and those who don't.
To understand recursion, we must first understand recursion.


On Fri, Oct 5, 2018 at 9:51 AM Guillaume Laforge <[hidden email]> wrote:
+1 (binding)

Built from source successfully.
Ran some console related smoke tests, and all went fine.

Guillaume


On Fri, Oct 5, 2018 at 8:17 AM Paul King <[hidden email]> wrote:

Dear development community,

I am happy to start the VOTE thread for a Groovy 2.5.3 release!

This release includes 46 bug fixes/improvements as outlined in the changelog:

Tag commit id: a05a9371f51112cb20f967d6ee204ea20bec2701

The artifacts to be voted on are located as follows (r29887).

Release artifacts are signed with a key from the following file:

Please vote on releasing this package as Apache Groovy 2.5.3.

Reminder on ASF release approval requirements for PMC members:
Hints on validating checksums/signatures (but replace md5sum with sha256sum):

The vote is open for the next 72 hours and passes if a majority of at least three +1 PMC votes are cast.

[ ] +1 Release Apache Groovy 2.5.3
[ ]  0 I don't have a strong opinion about this, but I assume it's ok
[ ] -1 Do not release Apache Groovy 2.5.3 because...

Here is my vote:

+1 (binding)



--
Guillaume Laforge
Apache Groovy committer & PMC Vice-President
Developer Advocate @ Google Cloud Platform

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Groovy 2.5.3

jwagenleitner
In reply to this post by paulk_asert
On Linux I am having issues with the convenience binaries. The bin files seem to have CRLF line endings and fail to run.

$ file ./groovy-2.5.2/bin/groovy
./groovy-2.5.2/bin/groovy: a /usr/bin/env sh script, ASCII text executable
$ ./groovy-2.5.2/bin/groovy --version
Groovy Version: 2.5.2 JVM: 1.8.0_181 Vendor: Oracle Corporation OS: Linux

$ file ./groovy-2.5.3/bin/groovy
./groovy-2.5.3/bin/groovy: a /usr/bin/env sh script, ASCII text executable, with CRLF line terminators
$ ./groovy-2.5.3/bin/groovy --version
/usr/bin/env: ‘sh\r’: No such file or directory

I checked and the source release zip has CRLF for the bin files in `src/bin` also.

Anyone else seeing the issue or maybe this is just something off in my environment?

John



On Thu, Oct 4, 2018 at 11:17 PM Paul King <[hidden email]> wrote:

Dear development community,

I am happy to start the VOTE thread for a Groovy 2.5.3 release!

This release includes 46 bug fixes/improvements as outlined in the changelog:

Tag commit id: a05a9371f51112cb20f967d6ee204ea20bec2701

The artifacts to be voted on are located as follows (r29887).

Release artifacts are signed with a key from the following file:

Please vote on releasing this package as Apache Groovy 2.5.3.

Reminder on ASF release approval requirements for PMC members:
Hints on validating checksums/signatures (but replace md5sum with sha256sum):

The vote is open for the next 72 hours and passes if a majority of at least three +1 PMC votes are cast.

[ ] +1 Release Apache Groovy 2.5.3
[ ]  0 I don't have a strong opinion about this, but I assume it's ok
[ ] -1 Do not release Apache Groovy 2.5.3 because...

Here is my vote:

+1 (binding)

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Groovy 2.5.3

paulk_asert
I just managed to check John's issues. Some things look a little strange. I'll re-roll the release jars.

Cheers, Paul.

On Sun, Oct 7, 2018 at 4:29 AM John Wagenleitner <[hidden email]> wrote:
On Linux I am having issues with the convenience binaries. The bin files seem to have CRLF line endings and fail to run.

$ file ./groovy-2.5.2/bin/groovy
./groovy-2.5.2/bin/groovy: a /usr/bin/env sh script, ASCII text executable
$ ./groovy-2.5.2/bin/groovy --version
Groovy Version: 2.5.2 JVM: 1.8.0_181 Vendor: Oracle Corporation OS: Linux

$ file ./groovy-2.5.3/bin/groovy
./groovy-2.5.3/bin/groovy: a /usr/bin/env sh script, ASCII text executable, with CRLF line terminators
$ ./groovy-2.5.3/bin/groovy --version
/usr/bin/env: ‘sh\r’: No such file or directory

I checked and the source release zip has CRLF for the bin files in `src/bin` also.

Anyone else seeing the issue or maybe this is just something off in my environment?

John



On Thu, Oct 4, 2018 at 11:17 PM Paul King <[hidden email]> wrote:

Dear development community,

I am happy to start the VOTE thread for a Groovy 2.5.3 release!

This release includes 46 bug fixes/improvements as outlined in the changelog:

Tag commit id: a05a9371f51112cb20f967d6ee204ea20bec2701

The artifacts to be voted on are located as follows (r29887).

Release artifacts are signed with a key from the following file:

Please vote on releasing this package as Apache Groovy 2.5.3.

Reminder on ASF release approval requirements for PMC members:
Hints on validating checksums/signatures (but replace md5sum with sha256sum):

The vote is open for the next 72 hours and passes if a majority of at least three +1 PMC votes are cast.

[ ] +1 Release Apache Groovy 2.5.3
[ ]  0 I don't have a strong opinion about this, but I assume it's ok
[ ] -1 Do not release Apache Groovy 2.5.3 because...

Here is my vote:

+1 (binding)

Reply | Threaded
Open this post in threaded view
|

[CANCELLED][VOTE] Release Apache Groovy 2.5.3

paulk_asert


On Mon, Oct 8, 2018 at 8:45 PM Paul King <[hidden email]> wrote:
I just managed to check John's issues. Some things look a little strange. I'll re-roll the release jars.

Cheers, Paul.

On Sun, Oct 7, 2018 at 4:29 AM John Wagenleitner <[hidden email]> wrote:
On Linux I am having issues with the convenience binaries. The bin files seem to have CRLF line endings and fail to run.

$ file ./groovy-2.5.2/bin/groovy
./groovy-2.5.2/bin/groovy: a /usr/bin/env sh script, ASCII text executable
$ ./groovy-2.5.2/bin/groovy --version
Groovy Version: 2.5.2 JVM: 1.8.0_181 Vendor: Oracle Corporation OS: Linux

$ file ./groovy-2.5.3/bin/groovy
./groovy-2.5.3/bin/groovy: a /usr/bin/env sh script, ASCII text executable, with CRLF line terminators
$ ./groovy-2.5.3/bin/groovy --version
/usr/bin/env: ‘sh\r’: No such file or directory

I checked and the source release zip has CRLF for the bin files in `src/bin` also.

Anyone else seeing the issue or maybe this is just something off in my environment?

John



On Thu, Oct 4, 2018 at 11:17 PM Paul King <[hidden email]> wrote:

Dear development community,

I am happy to start the VOTE thread for a Groovy 2.5.3 release!

This release includes 46 bug fixes/improvements as outlined in the changelog:

Tag commit id: a05a9371f51112cb20f967d6ee204ea20bec2701

The artifacts to be voted on are located as follows (r29887).

Release artifacts are signed with a key from the following file:

Please vote on releasing this package as Apache Groovy 2.5.3.

Reminder on ASF release approval requirements for PMC members:
Hints on validating checksums/signatures (but replace md5sum with sha256sum):

The vote is open for the next 72 hours and passes if a majority of at least three +1 PMC votes are cast.

[ ] +1 Release Apache Groovy 2.5.3
[ ]  0 I don't have a strong opinion about this, but I assume it's ok
[ ] -1 Do not release Apache Groovy 2.5.3 because...

Here is my vote:

+1 (binding)