Quantcast

[VOTE] Release Apache Groovy 2.4.10

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
12 messages Options
12
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[VOTE] Release Apache Groovy 2.4.10

paulk_asert
Dear community,

I am happy to start the VOTE thread for a Groovy 2.4.10 release!

This release includes 9 bug fixes/improvements as outlined in the changelog:
https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12318123&version=12339743

Tag: https://git1-us-west.apache.org/repos/asf?p=groovy.git;a=tag;h=refs/tags/GROOVY_2_4_10
Tag commit id: f2796bad0c5e5d1304e51331244b671ece60c351

The artifacts to be voted on are located as follows (r18648).
Source release: https://dist.apache.org/repos/dist/dev/groovy/2.4.10/sources
Convenience binaries:
https://dist.apache.org/repos/dist/dev/groovy/2.4.10/distribution

Release artifacts are signed with a key from the following file:
https://dist.apache.org/repos/dist/dev/groovy/KEYS

Please vote on releasing this package as Apache Groovy 2.4.10.

The vote is open for the next 72 hours and passes if a majority of at
least three +1 PMC votes are cast.

[ ] +1 Release Apache Groovy 2.4.10
[ ]  0 I don't have a strong opinion about this, but I assume it's ok
[ ] -1 Do not release Apache Groovy 2.4.10 because...

Here is my vote:

+1 (binding)
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Release Apache Groovy 2.4.10

Bahman Movaqar
On 09/03/17 23:29, Paul King wrote:
> Please vote on releasing this package as Apache Groovy 2.4.10.

+1

Thank you Groovy team for your efforts.

--
Bahman Movaqar

http://BahmanM.com - https://twitter.com/bahman__m
https://github.com/bahmanm - https://gist.github.com/bahmanm
PGP Key ID: 0x6AB5BD68 (keyserver2.pgp.com)


signature.asc (484 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Release Apache Groovy 2.4.10

Cédric Champeau
I'm tempted to send a +1, I've checked the signatures, but I have a weird error when building: https://scans.gradle.com/s/hgptywcc26pq2

Has anyone seen this before?

2017-03-10 19:51 GMT+01:00 Bahman Movaqar <[hidden email]>:
On 09/03/17 23:29, Paul King wrote:
> Please vote on releasing this package as Apache Groovy 2.4.10.

+1

Thank you Groovy team for your efforts.

--
Bahman Movaqar

http://BahmanM.com - https://twitter.com/bahman__m
https://github.com/bahmanm - https://gist.github.com/bahmanm
PGP Key ID: 0x6AB5BD68 (keyserver2.pgp.com)


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Release Apache Groovy 2.4.10

Guillaume Laforge
Administrator
I also get the same error:

:groovydocAll FAILED


FAILURE: Build failed with an exception.


* What went wrong:

Execution failed for task ':groovydocAll'.

> java.lang.VerifyError: Bad type on operand stack

  Exception Details:

    Location:

      org/codehaus/groovy/tools/groovydoc/GroovyRootDocBuilder.getJavaParser(Ljava/lang/String;Lorg/codehaus/groovy/antlr/SourceBuffer;)Lorg/codehaus/groovy/antlr/java/JavaRecognizer; @28: invokevirtual

    Reason:

      Type 'org/codehaus/groovy/antlr/java/JavaLexer' (current frame, stack[1]) is not assignable to 'groovyjarjarantlr/CharScanner'

    Current Frame:

      bci: @28

      flags: { }

      locals: { 'java/lang/String', 'org/codehaus/groovy/antlr/SourceBuffer', 'org/codehaus/groovy/antlr/UnicodeEscapingReader', 'org/codehaus/groovy/antlr/java/JavaLexer' }

      stack: { 'org/codehaus/groovy/antlr/UnicodeEscapingReader', 'org/codehaus/groovy/antlr/java/JavaLexer' }

    Bytecode:

      0x0000000: bb00 bb59 bb00 bd59 2ab7 00be 2bb7 00c1

      0x0000010: 4dbb 00c3 592c b700 c64e 2c2d b600 ca2d

      0x0000020: b800 ce3a 0419 042b b600 d219 04b0     



* Try:

Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.


BUILD FAILED


Total time: 4 mins 59.81 secs


On Fri, Mar 10, 2017 at 8:11 PM, Cédric Champeau <[hidden email]> wrote:
I'm tempted to send a +1, I've checked the signatures, but I have a weird error when building: https://scans.gradle.com/s/hgptywcc26pq2

Has anyone seen this before?

2017-03-10 19:51 GMT+01:00 Bahman Movaqar <[hidden email]>:
On 09/03/17 23:29, Paul King wrote:
> Please vote on releasing this package as Apache Groovy 2.4.10.

+1

Thank you Groovy team for your efforts.

--
Bahman Movaqar

http://BahmanM.com - https://twitter.com/bahman__m
https://github.com/bahmanm - https://gist.github.com/bahmanm
PGP Key ID: 0x6AB5BD68 (keyserver2.pgp.com)





--
Guillaume Laforge
Apache Groovy committer & PMC Vice-President
Developer Advocate @ Google Cloud Platform

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Release Apache Groovy 2.4.10

paulk_asert
What Java version are you using Guillaume?

On Sat, Mar 11, 2017 at 6:45 AM, Guillaume Laforge <[hidden email]> wrote:

> I also get the same error:
>
> :groovydocAll FAILED
>
>
> FAILURE: Build failed with an exception.
>
>
> * What went wrong:
>
> Execution failed for task ':groovydocAll'.
>
>> java.lang.VerifyError: Bad type on operand stack
>
>   Exception Details:
>
>     Location:
>
>
> org/codehaus/groovy/tools/groovydoc/GroovyRootDocBuilder.getJavaParser(Ljava/lang/String;Lorg/codehaus/groovy/antlr/SourceBuffer;)Lorg/codehaus/groovy/antlr/java/JavaRecognizer;
> @28: invokevirtual
>
>     Reason:
>
>       Type 'org/codehaus/groovy/antlr/java/JavaLexer' (current frame,
> stack[1]) is not assignable to 'groovyjarjarantlr/CharScanner'
>
>     Current Frame:
>
>       bci: @28
>
>       flags: { }
>
>       locals: { 'java/lang/String',
> 'org/codehaus/groovy/antlr/SourceBuffer',
> 'org/codehaus/groovy/antlr/UnicodeEscapingReader',
> 'org/codehaus/groovy/antlr/java/JavaLexer' }
>
>       stack: { 'org/codehaus/groovy/antlr/UnicodeEscapingReader',
> 'org/codehaus/groovy/antlr/java/JavaLexer' }
>
>     Bytecode:
>
>       0x0000000: bb00 bb59 bb00 bd59 2ab7 00be 2bb7 00c1
>
>       0x0000010: 4dbb 00c3 592c b700 c64e 2c2d b600 ca2d
>
>       0x0000020: b800 ce3a 0419 042b b600 d219 04b0
>
>
>
> * Try:
>
> Run with --stacktrace option to get the stack trace. Run with --info or
> --debug option to get more log output.
>
>
> BUILD FAILED
>
>
> Total time: 4 mins 59.81 secs
>
>
> On Fri, Mar 10, 2017 at 8:11 PM, Cédric Champeau <[hidden email]>
> wrote:
>>
>> I'm tempted to send a +1, I've checked the signatures, but I have a weird
>> error when building: https://scans.gradle.com/s/hgptywcc26pq2
>>
>> Has anyone seen this before?
>>
>> 2017-03-10 19:51 GMT+01:00 Bahman Movaqar <[hidden email]>:
>>>
>>> On 09/03/17 23:29, Paul King wrote:
>>> > Please vote on releasing this package as Apache Groovy 2.4.10.
>>>
>>> +1
>>>
>>> Thank you Groovy team for your efforts.
>>>
>>> --
>>> Bahman Movaqar
>>>
>>> http://BahmanM.com - https://twitter.com/bahman__m
>>> https://github.com/bahmanm - https://gist.github.com/bahmanm
>>> PGP Key ID: 0x6AB5BD68 (keyserver2.pgp.com)
>>>
>>
>
>
>
> --
> Guillaume Laforge
> Apache Groovy committer & PMC Vice-President
> Developer Advocate @ Google Cloud Platform
>
> Blog: http://glaforge.appspot.com/
> Social: @glaforge / Google+
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Release Apache Groovy 2.4.10

paulk_asert
I couldn't replicate on Ubuntu or Windows using 1.8.0_121.


On Sat, Mar 11, 2017 at 3:18 PM, Paul King <[hidden email]> wrote:

> What Java version are you using Guillaume?
>
> On Sat, Mar 11, 2017 at 6:45 AM, Guillaume Laforge <[hidden email]> wrote:
>> I also get the same error:
>>
>> :groovydocAll FAILED
>>
>>
>> FAILURE: Build failed with an exception.
>>
>>
>> * What went wrong:
>>
>> Execution failed for task ':groovydocAll'.
>>
>>> java.lang.VerifyError: Bad type on operand stack
>>
>>   Exception Details:
>>
>>     Location:
>>
>>
>> org/codehaus/groovy/tools/groovydoc/GroovyRootDocBuilder.getJavaParser(Ljava/lang/String;Lorg/codehaus/groovy/antlr/SourceBuffer;)Lorg/codehaus/groovy/antlr/java/JavaRecognizer;
>> @28: invokevirtual
>>
>>     Reason:
>>
>>       Type 'org/codehaus/groovy/antlr/java/JavaLexer' (current frame,
>> stack[1]) is not assignable to 'groovyjarjarantlr/CharScanner'
>>
>>     Current Frame:
>>
>>       bci: @28
>>
>>       flags: { }
>>
>>       locals: { 'java/lang/String',
>> 'org/codehaus/groovy/antlr/SourceBuffer',
>> 'org/codehaus/groovy/antlr/UnicodeEscapingReader',
>> 'org/codehaus/groovy/antlr/java/JavaLexer' }
>>
>>       stack: { 'org/codehaus/groovy/antlr/UnicodeEscapingReader',
>> 'org/codehaus/groovy/antlr/java/JavaLexer' }
>>
>>     Bytecode:
>>
>>       0x0000000: bb00 bb59 bb00 bd59 2ab7 00be 2bb7 00c1
>>
>>       0x0000010: 4dbb 00c3 592c b700 c64e 2c2d b600 ca2d
>>
>>       0x0000020: b800 ce3a 0419 042b b600 d219 04b0
>>
>>
>>
>> * Try:
>>
>> Run with --stacktrace option to get the stack trace. Run with --info or
>> --debug option to get more log output.
>>
>>
>> BUILD FAILED
>>
>>
>> Total time: 4 mins 59.81 secs
>>
>>
>> On Fri, Mar 10, 2017 at 8:11 PM, Cédric Champeau <[hidden email]>
>> wrote:
>>>
>>> I'm tempted to send a +1, I've checked the signatures, but I have a weird
>>> error when building: https://scans.gradle.com/s/hgptywcc26pq2
>>>
>>> Has anyone seen this before?
>>>
>>> 2017-03-10 19:51 GMT+01:00 Bahman Movaqar <[hidden email]>:
>>>>
>>>> On 09/03/17 23:29, Paul King wrote:
>>>> > Please vote on releasing this package as Apache Groovy 2.4.10.
>>>>
>>>> +1
>>>>
>>>> Thank you Groovy team for your efforts.
>>>>
>>>> --
>>>> Bahman Movaqar
>>>>
>>>> http://BahmanM.com - https://twitter.com/bahman__m
>>>> https://github.com/bahmanm - https://gist.github.com/bahmanm
>>>> PGP Key ID: 0x6AB5BD68 (keyserver2.pgp.com)
>>>>
>>>
>>
>>
>>
>> --
>> Guillaume Laforge
>> Apache Groovy committer & PMC Vice-President
>> Developer Advocate @ Google Cloud Platform
>>
>> Blog: http://glaforge.appspot.com/
>> Social: @glaforge / Google+
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Release Apache Groovy 2.4.10

paulk_asert
In reply to this post by Cédric Champeau
Cédric, there seems like Gradle 3.5-2017xxx mentioned in the logs
which I presume shouldn't be there if using gradlew. Or is that a scan
thing?

On Sat, Mar 11, 2017 at 5:11 AM, Cédric Champeau
<[hidden email]> wrote:

> I'm tempted to send a +1, I've checked the signatures, but I have a weird
> error when building: https://scans.gradle.com/s/hgptywcc26pq2
>
> Has anyone seen this before?
>
> 2017-03-10 19:51 GMT+01:00 Bahman Movaqar <[hidden email]>:
>>
>> On 09/03/17 23:29, Paul King wrote:
>> > Please vote on releasing this package as Apache Groovy 2.4.10.
>>
>> +1
>>
>> Thank you Groovy team for your efforts.
>>
>> --
>> Bahman Movaqar
>>
>> http://BahmanM.com - https://twitter.com/bahman__m
>> https://github.com/bahmanm - https://gist.github.com/bahmanm
>> PGP Key ID: 0x6AB5BD68 (keyserver2.pgp.com)
>>
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Release Apache Groovy 2.4.10

Guillaume Laforge
Administrator
In reply to this post by paulk_asert
Sorry, I was flying back home, couldn't get answer earlier:

$ java -version

java version "1.8.0_112"

Java(TM) SE Runtime Environment (build 1.8.0_112-b16)

Java HotSpot(TM) 64-Bit Server VM (build 25.112-b16, mixed mode)

(on a Mac)



On Sat, Mar 11, 2017 at 6:18 AM, Paul King <[hidden email]> wrote:
What Java version are you using Guillaume?

On Sat, Mar 11, 2017 at 6:45 AM, Guillaume Laforge <[hidden email]> wrote:
> I also get the same error:
>
> :groovydocAll FAILED
>
>
> FAILURE: Build failed with an exception.
>
>
> * What went wrong:
>
> Execution failed for task ':groovydocAll'.
>
>> java.lang.VerifyError: Bad type on operand stack
>
>   Exception Details:
>
>     Location:
>
>
> org/codehaus/groovy/tools/groovydoc/GroovyRootDocBuilder.getJavaParser(Ljava/lang/String;Lorg/codehaus/groovy/antlr/SourceBuffer;)Lorg/codehaus/groovy/antlr/java/JavaRecognizer;
> @28: invokevirtual
>
>     Reason:
>
>       Type 'org/codehaus/groovy/antlr/java/JavaLexer' (current frame,
> stack[1]) is not assignable to 'groovyjarjarantlr/CharScanner'
>
>     Current Frame:
>
>       bci: @28
>
>       flags: { }
>
>       locals: { 'java/lang/String',
> 'org/codehaus/groovy/antlr/SourceBuffer',
> 'org/codehaus/groovy/antlr/UnicodeEscapingReader',
> 'org/codehaus/groovy/antlr/java/JavaLexer' }
>
>       stack: { 'org/codehaus/groovy/antlr/UnicodeEscapingReader',
> 'org/codehaus/groovy/antlr/java/JavaLexer' }
>
>     Bytecode:
>
>       0x0000000: bb00 bb59 bb00 bd59 2ab7 00be 2bb7 00c1
>
>       0x0000010: 4dbb 00c3 592c b700 c64e 2c2d b600 ca2d
>
>       0x0000020: b800 ce3a 0419 042b b600 d219 04b0
>
>
>
> * Try:
>
> Run with --stacktrace option to get the stack trace. Run with --info or
> --debug option to get more log output.
>
>
> BUILD FAILED
>
>
> Total time: 4 mins 59.81 secs
>
>
> On Fri, Mar 10, 2017 at 8:11 PM, Cédric Champeau <[hidden email]>
> wrote:
>>
>> I'm tempted to send a +1, I've checked the signatures, but I have a weird
>> error when building: https://scans.gradle.com/s/hgptywcc26pq2
>>
>> Has anyone seen this before?
>>
>> 2017-03-10 19:51 GMT+01:00 Bahman Movaqar <[hidden email]>:
>>>
>>> On 09/03/17 23:29, Paul King wrote:
>>> > Please vote on releasing this package as Apache Groovy 2.4.10.
>>>
>>> +1
>>>
>>> Thank you Groovy team for your efforts.
>>>
>>> --
>>> Bahman Movaqar
>>>
>>> http://BahmanM.com - https://twitter.com/bahman__m
>>> https://github.com/bahmanm - https://gist.github.com/bahmanm
>>> PGP Key ID: 0x6AB5BD68 (keyserver2.pgp.com)
>>>
>>
>
>
>
> --
> Guillaume Laforge
> Apache Groovy committer & PMC Vice-President
> Developer Advocate @ Google Cloud Platform
>
> Blog: http://glaforge.appspot.com/
> Social: @glaforge / Google+



--
Guillaume Laforge
Apache Groovy committer & PMC Vice-President
Developer Advocate @ Google Cloud Platform

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Release Apache Groovy 2.4.10

jwagenleitner
In reply to this post by paulk_asert
+1

Just wanted to note that in testing I came across some method names in tests that had characters that are now no longer allowed in method names [1] [2].  I know this is related to the fix for GROOVY-6792, just thought it was odd that it seems to have worked in some cases before.



On Thu, Mar 9, 2017 at 2:29 PM, Paul King <[hidden email]> wrote:
Dear community,

I am happy to start the VOTE thread for a Groovy 2.4.10 release!

This release includes 9 bug fixes/improvements as outlined in the changelog:
https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12318123&version=12339743

Tag: https://git1-us-west.apache.org/repos/asf?p=groovy.git;a=tag;h=refs/tags/GROOVY_2_4_10
Tag commit id: f2796bad0c5e5d1304e51331244b671ece60c351

The artifacts to be voted on are located as follows (r18648).
Source release: https://dist.apache.org/repos/dist/dev/groovy/2.4.10/sources
Convenience binaries:
https://dist.apache.org/repos/dist/dev/groovy/2.4.10/distribution

Release artifacts are signed with a key from the following file:
https://dist.apache.org/repos/dist/dev/groovy/KEYS

Please vote on releasing this package as Apache Groovy 2.4.10.

The vote is open for the next 72 hours and passes if a majority of at
least three +1 PMC votes are cast.

[ ] +1 Release Apache Groovy 2.4.10
[ ]  0 I don't have a strong opinion about this, but I assume it's ok
[ ] -1 Do not release Apache Groovy 2.4.10 because...

Here is my vote:

+1 (binding)

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Release Apache Groovy 2.4.10

paulk_asert
Hi John, the Spock example is fine since that isn't left as the method
name by the time the test is run. I am puzzled how the other one could
have ever run.

Cheers, Paul.

On Sun, Mar 12, 2017 at 9:28 AM, John Wagenleitner
<[hidden email]> wrote:

> +1
>
> Just wanted to note that in testing I came across some method names in tests
> that had characters that are now no longer allowed in method names [1] [2].
> I know this is related to the fix for GROOVY-6792, just thought it was odd
> that it seems to have worked in some cases before.
>
> [1]
> https://github.com/grails/grails-core/blob/521f733530160407b92020ff0ed6430858767ed1/grails-test-suite-web/src/test/groovy/org/grails/web/codecs/CodecSpec.groovy#L40
>
> [2]
> https://github.com/grails/grails-core/blob/521f733530160407b92020ff0ed6430858767ed1/grails-core/src/test/groovy/org/grails/compiler/injection/DefaultDomainClassInjectorSpec.groovy#L17
>
> On Thu, Mar 9, 2017 at 2:29 PM, Paul King <[hidden email]> wrote:
>>
>> Dear community,
>>
>> I am happy to start the VOTE thread for a Groovy 2.4.10 release!
>>
>> This release includes 9 bug fixes/improvements as outlined in the
>> changelog:
>>
>> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12318123&version=12339743
>>
>> Tag:
>> https://git1-us-west.apache.org/repos/asf?p=groovy.git;a=tag;h=refs/tags/GROOVY_2_4_10
>> Tag commit id: f2796bad0c5e5d1304e51331244b671ece60c351
>>
>> The artifacts to be voted on are located as follows (r18648).
>> Source release:
>> https://dist.apache.org/repos/dist/dev/groovy/2.4.10/sources
>> Convenience binaries:
>> https://dist.apache.org/repos/dist/dev/groovy/2.4.10/distribution
>>
>> Release artifacts are signed with a key from the following file:
>> https://dist.apache.org/repos/dist/dev/groovy/KEYS
>>
>> Please vote on releasing this package as Apache Groovy 2.4.10.
>>
>> The vote is open for the next 72 hours and passes if a majority of at
>> least three +1 PMC votes are cast.
>>
>> [ ] +1 Release Apache Groovy 2.4.10
>> [ ]  0 I don't have a strong opinion about this, but I assume it's ok
>> [ ] -1 Do not release Apache Groovy 2.4.10 because...
>>
>> Here is my vote:
>>
>> +1 (binding)
>
>
12
Loading...