Re: groovy git commit: Revert "Bump gradle version to 4.0" and "Bump build-scan plugin version to 1.8"

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: groovy git commit: Revert "Bump gradle version to 4.0" and "Bump build-scan plugin version to 1.8"

Paul King-8
Build fails under Gradle 4?

On Fri, Jun 16, 2017 at 10:35 AM,  <[hidden email]> wrote:

> Repository: groovy
> Updated Branches:
>   refs/heads/master 88abc49e7 -> f9282ff13
>
>
> Revert "Bump gradle version to 4.0" and "Bump build-scan plugin version to 1.8"
>
>
> Project: http://git-wip-us.apache.org/repos/asf/groovy/repo
> Commit: http://git-wip-us.apache.org/repos/asf/groovy/commit/f9282ff1
> Tree: http://git-wip-us.apache.org/repos/asf/groovy/tree/f9282ff1
> Diff: http://git-wip-us.apache.org/repos/asf/groovy/diff/f9282ff1
>
> Branch: refs/heads/master
> Commit: f9282ff137937689c9533aab2b1bc21edf9ec990
> Parents: 88abc49
> Author: sunlan <[hidden email]>
> Authored: Fri Jun 16 08:34:58 2017 +0800
> Committer: sunlan <[hidden email]>
> Committed: Fri Jun 16 08:34:58 2017 +0800
>
> ----------------------------------------------------------------------
>  build.gradle                             |   4 ++--
>  gradle/wrapper/gradle-wrapper.jar        | Bin 54783 -> 54783 bytes
>  gradle/wrapper/gradle-wrapper.properties |   4 ++--
>  3 files changed, 4 insertions(+), 4 deletions(-)
> ----------------------------------------------------------------------
>
>
> http://git-wip-us.apache.org/repos/asf/groovy/blob/f9282ff1/build.gradle
> ----------------------------------------------------------------------
> diff --git a/build.gradle b/build.gradle
> index 9f7ee94..e59b82e 100644
> --- a/build.gradle
> +++ b/build.gradle
> @@ -51,7 +51,7 @@ buildscript {
>  }
>
>  plugins {
> -    id 'com.gradle.build-scan' version '1.8'
> +    id 'com.gradle.build-scan' version '1.6'
>      id 'me.champeau.buildscan-recipes' version '0.1.7'
>  }
>
> @@ -162,7 +162,7 @@ ext {
>      commonsHttpClientVersion = '3.1'
>      eclipseOsgiVersion = '3.9.1-v20140110-1610'
>      gparsVersion = '1.2.1'
> -    gradleVersion = '4.0'
> +    gradleVersion = '3.5'
>      ivyVersion = '2.4.0'
>      jansiVersion = '1.13'
>      jarjarVersion = '1.4.1'
>
> http://git-wip-us.apache.org/repos/asf/groovy/blob/f9282ff1/gradle/wrapper/gradle-wrapper.jar
> ----------------------------------------------------------------------
> diff --git a/gradle/wrapper/gradle-wrapper.jar b/gradle/wrapper/gradle-wrapper.jar
> index 819fafb..cb20deb 100644
> Binary files a/gradle/wrapper/gradle-wrapper.jar and b/gradle/wrapper/gradle-wrapper.jar differ
>
> http://git-wip-us.apache.org/repos/asf/groovy/blob/f9282ff1/gradle/wrapper/gradle-wrapper.properties
> ----------------------------------------------------------------------
> diff --git a/gradle/wrapper/gradle-wrapper.properties b/gradle/wrapper/gradle-wrapper.properties
> index 25737e9..540f96f 100644
> --- a/gradle/wrapper/gradle-wrapper.properties
> +++ b/gradle/wrapper/gradle-wrapper.properties
> @@ -1,6 +1,6 @@
> -#Fri Jun 16 08:20:30 CST 2017
> +#Fri Jun 16 08:33:40 CST 2017
>  distributionBase=GRADLE_USER_HOME
>  distributionPath=wrapper/dists
>  zipStoreBase=GRADLE_USER_HOME
>  zipStorePath=wrapper/dists
> -distributionUrl=https\://services.gradle.org/distributions/gradle-4.0-bin.zip
> +distributionUrl=https\://services.gradle.org/distributions/gradle-3.5-bin.zip
>
Reply | Threaded
Open this post in threaded view
|

Re: groovy git commit: Revert "Bump gradle version to 4.0" and "Bump build-scan plugin version to 1.8"

bo zhang
Just for your information.

I just bumped to Gradle 4.0 in one of my private projects and found there're a lot changes in Gradle 4.0, especially some basic internal API and some basic behavior of public API. Since I have to use some internal API, the only choice for me to keep compatible with both Gradle 3 and Gradle 4 is ungly reflection.

It seems a lot work to migrate to Gradle 4.

On Fri, Jun 16, 2017 at 1:59 PM, Paul King <[hidden email]> wrote:
Build fails under Gradle 4?

On Fri, Jun 16, 2017 at 10:35 AM,  <[hidden email]> wrote:
> Repository: groovy
> Updated Branches:
>   refs/heads/master 88abc49e7 -> f9282ff13
>
>
> Revert "Bump gradle version to 4.0" and "Bump build-scan plugin version to 1.8"
>
>
> Project: http://git-wip-us.apache.org/repos/asf/groovy/repo
> Commit: http://git-wip-us.apache.org/repos/asf/groovy/commit/f9282ff1
> Tree: http://git-wip-us.apache.org/repos/asf/groovy/tree/f9282ff1
> Diff: http://git-wip-us.apache.org/repos/asf/groovy/diff/f9282ff1
>
> Branch: refs/heads/master
> Commit: f9282ff137937689c9533aab2b1bc21edf9ec990
> Parents: 88abc49
> Author: sunlan <[hidden email]>
> Authored: Fri Jun 16 08:34:58 2017 +0800
> Committer: sunlan <[hidden email]>
> Committed: Fri Jun 16 08:34:58 2017 +0800
>
> ----------------------------------------------------------------------
>  build.gradle                             |   4 ++--
>  gradle/wrapper/gradle-wrapper.jar        | Bin 54783 -> 54783 bytes
>  gradle/wrapper/gradle-wrapper.properties |   4 ++--
>  3 files changed, 4 insertions(+), 4 deletions(-)
> ----------------------------------------------------------------------
>
>
> http://git-wip-us.apache.org/repos/asf/groovy/blob/f9282ff1/build.gradle
> ----------------------------------------------------------------------
> diff --git a/build.gradle b/build.gradle
> index 9f7ee94..e59b82e 100644
> --- a/build.gradle
> +++ b/build.gradle
> @@ -51,7 +51,7 @@ buildscript {
>  }
>
>  plugins {
> -    id 'com.gradle.build-scan' version '1.8'
> +    id 'com.gradle.build-scan' version '1.6'
>      id 'me.champeau.buildscan-recipes' version '0.1.7'
>  }
>
> @@ -162,7 +162,7 @@ ext {
>      commonsHttpClientVersion = '3.1'
>      eclipseOsgiVersion = '3.9.1-v20140110-1610'
>      gparsVersion = '1.2.1'
> -    gradleVersion = '4.0'
> +    gradleVersion = '3.5'
>      ivyVersion = '2.4.0'
>      jansiVersion = '1.13'
>      jarjarVersion = '1.4.1'
>
> http://git-wip-us.apache.org/repos/asf/groovy/blob/f9282ff1/gradle/wrapper/gradle-wrapper.jar
> ----------------------------------------------------------------------
> diff --git a/gradle/wrapper/gradle-wrapper.jar b/gradle/wrapper/gradle-wrapper.jar
> index 819fafb..cb20deb 100644
> Binary files a/gradle/wrapper/gradle-wrapper.jar and b/gradle/wrapper/gradle-wrapper.jar differ
>
> http://git-wip-us.apache.org/repos/asf/groovy/blob/f9282ff1/gradle/wrapper/gradle-wrapper.properties
> ----------------------------------------------------------------------
> diff --git a/gradle/wrapper/gradle-wrapper.properties b/gradle/wrapper/gradle-wrapper.properties
> index 25737e9..540f96f 100644
> --- a/gradle/wrapper/gradle-wrapper.properties
> +++ b/gradle/wrapper/gradle-wrapper.properties
> @@ -1,6 +1,6 @@
> -#Fri Jun 16 08:20:30 CST 2017
> +#Fri Jun 16 08:33:40 CST 2017
>  distributionBase=GRADLE_USER_HOME
>  distributionPath=wrapper/dists
>  zipStoreBase=GRADLE_USER_HOME
>  zipStorePath=wrapper/dists
> -distributionUrl=https\://services.gradle.org/distributions/gradle-4.0-bin.zip
> +distributionUrl=https\://services.gradle.org/distributions/gradle-3.5-bin.zip
>

Reply | Threaded
Open this post in threaded view
|

Re: groovy git commit: Revert "Bump gradle version to 4.0" and "Bump build-scan plugin version to 1.8"

Daniel Sun
In reply to this post by Paul King-8
Hi Paul,

      The following error occurred after upgraded gradle to 4.0.
       
Script '/home/travis/build/apache/groovy/gradle/quality.gradle' line: 143
* What went wrong:
A problem occurred evaluating script.
> No signature of method: org.gradle.api.internal.file.collections.DefaultConfigurableFileCollection.include() is applicable for argument types: (java.lang.String) values: [**/*.class]
  Possible solutions: indexed(), indexed(int)

P.S.  the code in line 143 is `temp.include '**/*.class'`

Cheers,
Daniel.Sun