I attached both a patch and a testcase for GROOVY-1236 (support for using closures as parameters for unique()).
Please let me know if this is ok or something needs to be changed, I have some more in the pipeline.
By the way, I wondered what the best way is to name the testcase. I see a CollectionTest.groovy, which tests unique() (and unique only, which is kind of weird). Then there is a ListTest.groovy, which includes one test using unique().
Maybe for bug fixing we should name testcases after the bug number, like Groovy1236.groovy in my case. Those bug specific tests can be incorporated into other more general testcases when the bug fix is believed to be stable. What do you think?