Nextflow joint build

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Nextflow joint build

Paolo Di Tommaso
Hi, 

Is is possible to update the Nextflow joint build so that it's tested against Groovy 2.4.x and 2.5.x (instead 2.3.x and 2.4.x). 



Thanks, 
Paolo

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Nextflow joint build

paulk_asert
Done.

On Tue, Apr 4, 2017 at 10:56 PM, Paolo Di Tommaso <[hidden email]> wrote:
Hi, 

Is is possible to update the Nextflow joint build so that it's tested against Groovy 2.4.x and 2.5.x (instead 2.3.x and 2.4.x). 



Thanks, 
Paolo


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Nextflow joint build

Paolo Di Tommaso
Thanks!

p

On Tue, Apr 4, 2017 at 11:12 PM, Paul King <[hidden email]> wrote:
Done.

On Tue, Apr 4, 2017 at 10:56 PM, Paolo Di Tommaso <[hidden email]> wrote:
Hi, 

Is is possible to update the Nextflow joint build so that it's tested against Groovy 2.4.x and 2.5.x (instead 2.3.x and 2.4.x). 



Thanks, 
Paolo



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Nextflow joint build

Paolo Di Tommaso
Interesting, all nextflow tests are green with 2.5.0-SNAPSHOT but I'm getting several failures with 2.5.0-alpha-1

p

On Wed, Apr 5, 2017 at 9:18 AM, Paolo Di Tommaso <[hidden email]> wrote:
Thanks!

p

On Tue, Apr 4, 2017 at 11:12 PM, Paul King <[hidden email]> wrote:
Done.

On Tue, Apr 4, 2017 at 10:56 PM, Paolo Di Tommaso <[hidden email]> wrote:
Hi, 

Is is possible to update the Nextflow joint build so that it's tested against Groovy 2.4.x and 2.5.x (instead 2.3.x and 2.4.x). 



Thanks, 
Paolo




Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Nextflow joint build

paulk_asert
What errors are you getting?

I'm on holidays, so only have my travel laptop with windows and limited bandwidth to update my ubuntu vms. On windows there were over 100 failed tests even on 2.4.10.

Cheers, Paul.

On Thu, Apr 6, 2017 at 2:42 AM, Paolo Di Tommaso <[hidden email]> wrote:
Interesting, all nextflow tests are green with 2.5.0-SNAPSHOT but I'm getting several failures with 2.5.0-alpha-1

p


On Wed, Apr 5, 2017 at 9:18 AM, Paolo Di Tommaso <[hidden email]> wrote:
Thanks!

p

On Tue, Apr 4, 2017 at 11:12 PM, Paul King <[hidden email]> wrote:
Done.

On Tue, Apr 4, 2017 at 10:56 PM, Paolo Di Tommaso <[hidden email]> wrote:
Hi, 

Is is possible to update the Nextflow joint build so that it's tested against Groovy 2.4.x and 2.5.x (instead 2.3.x and 2.4.x). 



Thanks, 
Paolo





Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Nextflow joint build

Paolo Di Tommaso
No hurry. Some failures are caused by this issue: 


Others I still need to investigate. 


p

On Thu, Apr 6, 2017 at 4:28 AM, Paul King <[hidden email]> wrote:
What errors are you getting?

I'm on holidays, so only have my travel laptop with windows and limited bandwidth to update my ubuntu vms. On windows there were over 100 failed tests even on 2.4.10.

Cheers, Paul.

On Thu, Apr 6, 2017 at 2:42 AM, Paolo Di Tommaso <[hidden email]> wrote:
Interesting, all nextflow tests are green with 2.5.0-SNAPSHOT but I'm getting several failures with 2.5.0-alpha-1

p


On Wed, Apr 5, 2017 at 9:18 AM, Paolo Di Tommaso <[hidden email]> wrote:
Thanks!

p

On Tue, Apr 4, 2017 at 11:12 PM, Paul King <[hidden email]> wrote:
Done.

On Tue, Apr 4, 2017 at 10:56 PM, Paolo Di Tommaso <[hidden email]> wrote:
Hi, 

Is is possible to update the Nextflow joint build so that it's tested against Groovy 2.4.x and 2.5.x (instead 2.3.x and 2.4.x). 



Thanks, 
Paolo






Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Nextflow joint build

Paolo Di Tommaso
In reply to this post by Paolo Di Tommaso
What exactly 2.5.0-SNAPSHOT represent? 

All Nextflow tests are green on the joint built using Groovy 2.5.0-SNAPSHOT but it can't even compile it locally when using 2.5.0-beta-1 


p

On Wed, Apr 5, 2017 at 6:42 PM, Paolo Di Tommaso <[hidden email]> wrote:
Interesting, all nextflow tests are green with 2.5.0-SNAPSHOT but I'm getting several failures with 2.5.0-alpha-1

p


On Wed, Apr 5, 2017 at 9:18 AM, Paolo Di Tommaso <[hidden email]> wrote:
Thanks!

p

On Tue, Apr 4, 2017 at 11:12 PM, Paul King <[hidden email]> wrote:
Done.

On Tue, Apr 4, 2017 at 10:56 PM, Paolo Di Tommaso <[hidden email]> wrote:
Hi, 

Is is possible to update the Nextflow joint build so that it's tested against Groovy 2.4.x and 2.5.x (instead 2.3.x and 2.4.x). 



Thanks, 
Paolo





Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Nextflow joint build

Paolo Di Tommaso
This is one of the issue:



 It looks like that 2.5 branch has a lot of regressions with CompileStatic .. is that possible? 


Cheers,
Paolo

On Tue, Jun 6, 2017 at 10:29 PM, Paolo Di Tommaso <[hidden email]> wrote:
What exactly 2.5.0-SNAPSHOT represent? 

All Nextflow tests are green on the joint built using Groovy 2.5.0-SNAPSHOT but it can't even compile it locally when using 2.5.0-beta-1 


p

On Wed, Apr 5, 2017 at 6:42 PM, Paolo Di Tommaso <[hidden email]> wrote:
Interesting, all nextflow tests are green with 2.5.0-SNAPSHOT but I'm getting several failures with 2.5.0-alpha-1

p


On Wed, Apr 5, 2017 at 9:18 AM, Paolo Di Tommaso <[hidden email]> wrote:
Thanks!

p

On Tue, Apr 4, 2017 at 11:12 PM, Paul King <[hidden email]> wrote:
Done.

On Tue, Apr 4, 2017 at 10:56 PM, Paolo Di Tommaso <[hidden email]> wrote:
Hi, 

Is is possible to update the Nextflow joint build so that it's tested against Groovy 2.4.x and 2.5.x (instead 2.3.x and 2.4.x). 



Thanks, 
Paolo






Loading...