Quantcast

Groovy eclipse plugin doesn¹t work with eclipse 3.6.1 on a mac

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Groovy eclipse plugin doesn¹t work with eclipse 3.6.1 on a mac

mpurdy
Groovy eclipse plugin doesn’t work with eclipse 3.6.1 on a mac
After installing eclipse 3.6.1 using :  eclipse-SDK-3.6.1-macosx-cocoa-x86_64.tar

I use the follow update site for groovy plugin:
http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e3.6/


I get the following error:
Only one of the following can be installed at once:
    Java Development Tools Core 3.6.1.xx-20101007-1100-e36-RC2 (org.eclipse.jdt.core 3.6.1.xx-20101007-1100-e36-RC2)
    Java Development Tools Core 3.6.0.xx-20100630-0900-e36 (org.eclipse.jdt.core 3.6.0.xx-20100630-0900-e36)
    Java Development Tools Core 3.6.1.v_A68_R36x (org.eclipse.jdt.core 3.6.1.v_A68_R36x)
  Cannot satisfy dependency:
    From: Shared profile 1.0.0.1284044844810 (SharedProfile_SDKProfile 1.0.0.1284044844810)
    To: org.eclipse.jdt.core [3.6.1.v_A68_R36x]
  Cannot satisfy dependency:
    From: Groovy-Eclipse Feature 2.1.0.xx-20101007-1100-e36-RC2 (org.codehaus.groovy.eclipse.feature.feature.group 2.1.0.xx-20101007-1100-e36-RC2)
    To: org.codehaus.groovy.jdt.patch.feature.group [2.1.0.xx-20101007-1100-e36-RC2]
  Cannot satisfy dependency:
    From: Eclipse Project SDK 3.6.1.r361_v20100714-0800-7Q7m6DDaKf5o2z-L9LxPSe6ygafz-KKIqk1rr_3j4dn7J (org.eclipse.sdk.feature.group 3.6.1.r361_v20100714-0800-7Q7m6DDaKf5o2z-L9LxPSe6ygafz-KKIqk1rr_3j4dn7J)
    To: org.eclipse.jdt.feature.group [3.6.1.r361_v20100714-0800-7z8XFUSFLFlmgLc5z-Bvrt8-HVkH]
  Cannot satisfy dependency:
    From: Eclipse SDK 3.6.1.M20100909-0800 (org.eclipse.sdk.ide 3.6.1.M20100909-0800)
    To: org.eclipse.sdk.feature.group [3.6.1.r361_v20100714-0800-7Q7m6DDaKf5o2z-L9LxPSe6ygafz-KKIqk1rr_3j4dn7J]
  Cannot satisfy dependency:
    From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.1.0.xx-20101007-1100-e36-RC2 Eclipse Java Development Tools 3.6.1.r361_v20100714-0800-7z8XFUSFLFlmgLc5z-Bvrt8-HVkH (org.eclipse.jdt.feature.group 3.6.1.r361_v20100714-0800-7z8XFUSFLFlmgLc5z-Bvrt8-HVkH)
    To: org.eclipse.jdt.core [3.6.1.xx-20101007-1100-e36-RC2]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Groovy eclipse plugin doesn¹t work with eclipse 3.6.1 on a mac

mpurdy
i believe the problem is the groovy plugin doesnt work with eclipse 3.6.1  because the groovy plugin works on cent OS 5.5. with eclipse 3.6, Windows XP SP3 with eclipse 3.6, and red hat 5.3 with eclipse 3.5.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Groovy eclipse plugin doesn¹t work with eclipse 3.6.1 on a mac

mpurdy
no, it doesnt work on eclipse 3.6.0 either

i think it is groovy plugin 2.1.0.xx because the centos uses 2.0.2.  however, it uses the same update site.  how can i get 2.0.2 from the update site?


errror:

Cannot complete the install because of a conflicting dependency.
  Software being installed: Groovy-Eclipse Feature 2.1.0.xx-20101007-1100-e36-RC2 (org.codehaus.groovy.eclipse.feature.feature.group 2.1.0.xx-20101007-1100-e36-RC2)
  Software currently installed: Shared profile 1.0.0.1276013181170 (SharedProfile_SDKProfile 1.0.0.1276013181170)
  Only one of the following can be installed at once:
    Java Development Tools Core 3.6.1.xx-20101007-1100-e36-RC2 (org.eclipse.jdt.core 3.6.1.xx-20101007-1100-e36-RC2)
    Java Development Tools Core 3.6.0.v_A58 (org.eclipse.jdt.core 3.6.0.v_A58)
  Cannot satisfy dependency:
    From: Shared profile 1.0.0.1276013181170 (SharedProfile_SDKProfile 1.0.0.1276013181170)
    To: org.eclipse.jdt.core [3.6.0.v_A58]
  Cannot satisfy dependency:
    From: Shared profile 1.0.0.1276013181170 (SharedProfile_SDKProfile 1.0.0.1276013181170)
    To: org.eclipse.jdt.feature.group [3.6.0.v20100526-0800-7z8XFUJFMTfCWGoVuHImpms9H155]
  Cannot satisfy dependency:
    From: Groovy-Eclipse Feature 2.1.0.xx-20101007-1100-e36-RC2 (org.codehaus.groovy.eclipse.feature.feature.group 2.1.0.xx-20101007-1100-e36-RC2)
    To: org.codehaus.groovy.jdt.patch.feature.group [2.1.0.xx-20101007-1100-e36-RC2]
  Cannot satisfy dependency:
    From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.1.0.xx-20101007-1100-e36-RC2 Eclipse Java Development Tools 3.6.0.v20100526-0800-7z8XFUJFMTfCWGoVuHImpms9H155 (org.eclipse.jdt.feature.group 3.6.0.v20100526-0800-7z8XFUJFMTfCWGoVuHImpms9H155)
    To: org.eclipse.jdt.core [3.6.1.xx-20101007-1100-e36-RC2]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Groovy eclipse plugin doesn¹t work with eclipse 3.6.1 on a mac

mpurdy
In reply to this post by mpurdy
no, it doesnt work on eclipse 3.6.0 either

i think it is groovy plugin 2.1.0.xx because the centos uses 2.0.2.  however, it uses the same update site.  how can i get 2.0.2 from the update site?


errror:

Cannot complete the install because of a conflicting dependency.
  Software being installed: Groovy-Eclipse Feature 2.1.0.xx-20101007-1100-e36-RC2 (org.codehaus.groovy.eclipse.feature.feature.group 2.1.0.xx-20101007-1100-e36-RC2)
  Software currently installed: Shared profile 1.0.0.1276013181170 (SharedProfile_SDKProfile 1.0.0.1276013181170)
  Only one of the following can be installed at once:
    Java Development Tools Core 3.6.1.xx-20101007-1100-e36-RC2 (org.eclipse.jdt.core 3.6.1.xx-20101007-1100-e36-RC2)
    Java Development Tools Core 3.6.0.v_A58 (org.eclipse.jdt.core 3.6.0.v_A58)
  Cannot satisfy dependency:
    From: Shared profile 1.0.0.1276013181170 (SharedProfile_SDKProfile 1.0.0.1276013181170)
    To: org.eclipse.jdt.core [3.6.0.v_A58]
  Cannot satisfy dependency:
    From: Shared profile 1.0.0.1276013181170 (SharedProfile_SDKProfile 1.0.0.1276013181170)
    To: org.eclipse.jdt.feature.group [3.6.0.v20100526-0800-7z8XFUJFMTfCWGoVuHImpms9H155]
  Cannot satisfy dependency:
    From: Groovy-Eclipse Feature 2.1.0.xx-20101007-1100-e36-RC2 (org.codehaus.groovy.eclipse.feature.feature.group 2.1.0.xx-20101007-1100-e36-RC2)
    To: org.codehaus.groovy.jdt.patch.feature.group [2.1.0.xx-20101007-1100-e36-RC2]
  Cannot satisfy dependency:
    From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.1.0.xx-20101007-1100-e36-RC2 Eclipse Java Development Tools 3.6.0.v20100526-0800-7z8XFUJFMTfCWGoVuHImpms9H155 (org.eclipse.jdt.feature.group 3.6.0.v20100526-0800-7z8XFUJFMTfCWGoVuHImpms9H155)
    To: org.eclipse.jdt.core [3.6.1.xx-20101007-1100-e36-RC2]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Groovy eclipse plugin doesn¹t work with eclipse 3.6.1 on a mac

Andrew Eisenberg
In reply to this post by mpurdy
2.0.2 will not install on 3.6.1, but 2.1.0.RC2 will.

Do you have multiple update sites for Groovy-Eclipse in your update
manager (eg- the release and the development)?  Also, do you have
"Check all update sites..." enabled?  The line below makes me think
like the update manager wants to install both versions at the same
time.

I'd recommend unchecking "Check all update sites..." and trying again.

On Thu, Oct 14, 2010 at 2:13 PM, Matthew Purdy
<[hidden email]> wrote:
> Java Development Tools Core 3.6.1.xx-20101007-1100-e36-RC2
> (org.eclipse.jdt.core 3.6.1.xx-20101007-1100-e36-RC2)
>     Java Development Tools Core 3.6.0.xx-20100630-0900-e36
> (org.eclipse.jdt.core 3.6.0.xx-20100630-0900-e36)

Also, do you have any other third party plugins installed?

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Groovy eclipse plugin doesn¹t work with eclipse 3.6.1 on a mac

mpurdy

Yes, that was it....thanx

I re-downloaded a clean copy of eclipse 3.6.1 and using the eclipse plugin
site and it worked (I must of had two updates for groovy with the check all
update sites)


On 10/15/10 12:59 AM, "Andrew Eisenberg" <[hidden email]> wrote:

> 2.0.2 will not install on 3.6.1, but 2.1.0.RC2 will.
>
> Do you have multiple update sites for Groovy-Eclipse in your update
> manager (eg- the release and the development)?  Also, do you have
> "Check all update sites..." enabled?  The line below makes me think
> like the update manager wants to install both versions at the same
> time.
>
> I'd recommend unchecking "Check all update sites..." and trying again.
>
> On Thu, Oct 14, 2010 at 2:13 PM, Matthew Purdy
> <[hidden email]> wrote:
>> Java Development Tools Core 3.6.1.xx-20101007-1100-e36-RC2
>> (org.eclipse.jdt.core 3.6.1.xx-20101007-1100-e36-RC2)
>>     Java Development Tools Core 3.6.0.xx-20100630-0900-e36
>> (org.eclipse.jdt.core 3.6.0.xx-20100630-0900-e36)
>
> Also, do you have any other third party plugins installed?
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>     http://xircles.codehaus.org/manage_email
>
>



---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Loading...