Groovy 2.5.x @Canonical annotation and IntelliJ IDEA

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Groovy 2.5.x @Canonical annotation and IntelliJ IDEA

Paolo Di Tommaso
I've noticed that, after migrating to Groovy 2.5.x, IntelliJ IDEA is marking with an error instantiation of classes annotated with @Canonical annotation. 

The error reported by IDEA is "Cannot apply default constructor for class Xxx", however the application is correctly compiled. 

I'm inclined to think that's an IDEA issue, however I was wondering if this is somehow expected by the changes introduced by Groovy 2.5.x and if any workaround is available. 


Cheers,
Paolo