Groovy 2.5.* missing in maven central & jcenter

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Groovy 2.5.* missing in maven central & jcenter

Tommy Svensson
Hello Groovy fans,

I’m using Groovy and want it to work on later JDKs than 1.8. Apparently that requires version 2.5 and up. The problem I’m finding is that this version is not downloadable by maven. It is not in maven central nor bintrays jcenter. Some files are actually downloaded: javadoc, groovydoc and sources! But no binary jars. It can clearly be seen here: http://jcenter.bintray.com/org/codehaus/groovy/groovy-all/2.5.2/

The same goes for 2.5.0 and 2.5.1.

Why is that ? 

/Tommy

 

--


signature.asc (270 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Groovy 2.5.* missing in maven central & jcenter

paulk_asert

Depending on what you are trying to do, you might get some way with 2.4.x on JDKs above 8 but 2.5 and 3 alphas have improvements and fixes in some areas. You might still get certain currently benign warnings even with those versions.

Re packaging, please read the info in the release notes about repackaging due to JDK9+ modules:
http://groovy-lang.org/releasenotes/groovy-2.5.html

TL;DR: There is no longer a "fat" all jar just a "fat" all pom.

Cheers, Paul.


On Sat, Sep 1, 2018 at 6:51 PM Tommy Svensson <[hidden email]> wrote:
Hello Groovy fans,

I’m using Groovy and want it to work on later JDKs than 1.8. Apparently that requires version 2.5 and up. The problem I’m finding is that this version is not downloadable by maven. It is not in maven central nor bintrays jcenter. Some files are actually downloaded: javadoc, groovydoc and sources! But no binary jars. It can clearly be seen here: http://jcenter.bintray.com/org/codehaus/groovy/groovy-all/2.5.2/

The same goes for 2.5.0 and 2.5.1.

Why is that ? 

/Tommy

 

--

Reply | Threaded
Open this post in threaded view
|

Re: Groovy 2.5.* missing in maven central & jcenter

ericksn
In reply to this post by Tommy Svensson

Groovy , since 2.5.* does not support the all version. You have to get it by module

 

https://search.maven.org/search?q=g:org.codehaus.groovy%20AND%20v:2.5.2

 

 

Erick Nelson

Senior Developer – IT

HD Supply Facilities Maintenance

(858) 740-6523

 

 

From: Tommy Svensson <[hidden email]>
Reply-To: <[hidden email]>
Date: Saturday, September 1, 2018 at 1:51 AM
To: <[hidden email]>
Subject: Groovy 2.5.* missing in maven central & jcenter

 

Hello Groovy fans,

 

I’m using Groovy and want it to work on later JDKs than 1.8. Apparently that requires version 2.5 and up. The problem I’m finding is that this version is not downloadable by maven. It is not in maven central nor bintrays jcenter. Some files are actually downloaded: javadoc, groovydoc and sources! But no binary jars. It can clearly be seen here: http://jcenter.bintray.com/org/codehaus/groovy/groovy-all/2.5.2/

 

The same goes for 2.5.0 and 2.5.1.

 

Why is that ? 

 

/Tommy

 

 

 

--