Groovy 2.5.0 IntelliJ support ?

classic Classic list List threaded Threaded
6 messages Options
MG
Reply | Threaded
Open this post in threaded view
|

Groovy 2.5.0 IntelliJ support ?

MG
Since the Groovy 3.0 ticket
(https://youtrack.jetbrains.com/issue/IDEA-188050) just got updated
(thanks to everyone who voted): Do we know what the status for Groovy
2.5.0 IntelliJ support is ?
The release is around the corner and has some major new features
(http://groovy-lang.org/releasenotes/groovy-2.5.html) which require
Intellisense support -  do we need a ticket for that (to speed things
up), Daniil, or is support already underway ?-)
Cheers,
mg



Reply | Threaded
Open this post in threaded view
|

Re: Groovy 2.5.0 IntelliJ support ?

Алексей Афанасьев
Hi! Partial support for 2.5.0 was announced in 2017.2, but there are several features without proper handling still, for example @NamedParam. I think we will take a look at them soon.

Alexey Afanasiev.

2018-05-28 23:22 GMT+03:00 MG <[hidden email]>:
Since the Groovy 3.0 ticket (https://youtrack.jetbrains.com/issue/IDEA-188050) just got updated (thanks to everyone who voted): Do we know what the status for Groovy 2.5.0 IntelliJ support is ?
The release is around the corner and has some major new features (http://groovy-lang.org/releasenotes/groovy-2.5.html) which require Intellisense support -  do we need a ticket for that (to speed things up), Daniil, or is support already underway ?-)
Cheers,
mg




Reply | Threaded
Open this post in threaded view
|

Re: Groovy 2.5.0 IntelliJ support ?

Daniel.Sun
Thanks for your nice work!

Cheers,
Daniel.Sun




--
Sent from: http://groovy.329449.n5.nabble.com/Groovy-Users-f329450.html
Daniel Sun
Apache Groovy committer

Blog: http://blog.sunlan.me
Twitter: @daniel_sun
Reply | Threaded
Open this post in threaded view
|

Re: Groovy 2.5.0 IntelliJ support ?

paulk_asert
Actually, we still have more work to do in Groovy's compiler for @NamedParam too.

On Tue, May 29, 2018 at 8:21 PM, Daniel.Sun <[hidden email]> wrote:
Thanks for your nice work!

Cheers,
Daniel.Sun




--
Sent from: http://groovy.329449.n5.nabble.com/Groovy-Users-f329450.html

MG
Reply | Threaded
Open this post in threaded view
|

Re: Groovy 2.5.0 IntelliJ support ?

MG
In reply to this post by Алексей Афанасьев
Hi Alexey,

thank you for the information, I have created an issue for full Groovy 2.5 support.

Cheers,
mg


On 29.05.2018 11:44, Алексей Афанасьев wrote:
Hi! Partial support for 2.5.0 was announced in 2017.2, but there are several features without proper handling still, for example @NamedParam. I think we will take a look at them soon.

Alexey Afanasiev.

2018-05-28 23:22 GMT+03:00 MG <[hidden email]>:
Since the Groovy 3.0 ticket (https://youtrack.jetbrains.com/issue/IDEA-188050) just got updated (thanks to everyone who voted): Do we know what the status for Groovy 2.5.0 IntelliJ support is ?
The release is around the corner and has some major new features (http://groovy-lang.org/releasenotes/groovy-2.5.html) which require Intellisense support -  do we need a ticket for that (to speed things up), Daniil, or is support already underway ?-)
Cheers,
mg





Reply | Threaded
Open this post in threaded view
|

Re: Groovy 2.5.0 IntelliJ support ?

Алексей Афанасьев
It looks like @NamedDelegate feature has a serious bug https://issues.apache.org/jira/browse/GROOVY-8637. Incremental compilation are used by Intellij Idea nearly always, so if have a method with two @NamedDelegate's your compilation will be failed.

Alexey Afanasiev.

2018-06-01 22:08 GMT+03:00 MG <[hidden email]>:
Hi Alexey,

thank you for the information, I have created an issue for full Groovy 2.5 support.

Cheers,
mg



On 29.05.2018 11:44, Алексей Афанасьев wrote:
Hi! Partial support for 2.5.0 was announced in 2017.2, but there are several features without proper handling still, for example @NamedParam. I think we will take a look at them soon.

Alexey Afanasiev.

2018-05-28 23:22 GMT+03:00 MG <[hidden email]>:
Since the Groovy 3.0 ticket (https://youtrack.jetbrains.com/issue/IDEA-188050) just got updated (thanks to everyone who voted): Do we know what the status for Groovy 2.5.0 IntelliJ support is ?
The release is around the corner and has some major new features (http://groovy-lang.org/releasenotes/groovy-2.5.html) which require Intellisense support -  do we need a ticket for that (to speed things up), Daniil, or is support already underway ?-)
Cheers,
mg