Failing joint build

classic Classic list List threaded Threaded
11 messages Options
12
Reply | Threaded
Open this post in threaded view
|

Failing joint build

Paolo Di Tommaso
Daer maintainers, 

The Nextflow joint build is failing with this error message.

System.getenv('CI_GROOVY_VERSION') == GroovySystem.getVersion()
       |                           |               |
       2.5.6-SNAPSHOT              |               2.5.5
                                   false
                                   10 differences (28% similarity)
                                   2.5.(6-SNAPSHOT)
                                   2.5.(5---------)


It looks the Groovy runtime version is not matching the declared version by the `CI_GROOVY_VERSION` env var. 

Could you please give it a look. 


Cheers,
Paolo

Reply | Threaded
Open this post in threaded view
|

Re: Failing joint build

Paolo Di Tommaso
Hi devs,

Sorry if I insist on this, it may be that version string has not been updated on the 2.5.6 snapshot and therefore it's failing? 


p

On Mon, Jan 7, 2019 at 8:16 PM Paolo Di Tommaso <[hidden email]> wrote:
Daer maintainers, 

The Nextflow joint build is failing with this error message.

System.getenv('CI_GROOVY_VERSION') == GroovySystem.getVersion()
       |                           |               |
       2.5.6-SNAPSHOT              |               2.5.5
                                   false
                                   10 differences (28% similarity)
                                   2.5.(6-SNAPSHOT)
                                   2.5.(5---------)


It looks the Groovy runtime version is not matching the declared version by the `CI_GROOVY_VERSION` env var. 

Could you please give it a look. 


Cheers,
Paolo

Reply | Threaded
Open this post in threaded view
|

Re: Failing joint build

paulk_asert
I get 2.5.6-SNAPSHOT as the version when I use locally built snapshots. I presume it is something specific to the Nextflow build but haven't had time to check yet.

On Fri, Jan 11, 2019 at 6:25 PM Paolo Di Tommaso <[hidden email]> wrote:
Hi devs,

Sorry if I insist on this, it may be that version string has not been updated on the 2.5.6 snapshot and therefore it's failing? 


p

On Mon, Jan 7, 2019 at 8:16 PM Paolo Di Tommaso <[hidden email]> wrote:
Daer maintainers, 

The Nextflow joint build is failing with this error message.

System.getenv('CI_GROOVY_VERSION') == GroovySystem.getVersion()
       |                           |               |
       2.5.6-SNAPSHOT              |               2.5.5
                                   false
                                   10 differences (28% similarity)
                                   2.5.(6-SNAPSHOT)
                                   2.5.(5---------)


It looks the Groovy runtime version is not matching the declared version by the `CI_GROOVY_VERSION` env var. 

Could you please give it a look. 


Cheers,
Paolo

Reply | Threaded
Open this post in threaded view
|

Re: Failing joint build

Paolo Di Tommaso
I'm raising again this issue. No way to fix it?


p

On Fri, Jan 11, 2019 at 12:51 PM Paul King <[hidden email]> wrote:
I get 2.5.6-SNAPSHOT as the version when I use locally built snapshots. I presume it is something specific to the Nextflow build but haven't had time to check yet.

On Fri, Jan 11, 2019 at 6:25 PM Paolo Di Tommaso <[hidden email]> wrote:
Hi devs,

Sorry if I insist on this, it may be that version string has not been updated on the 2.5.6 snapshot and therefore it's failing? 


p

On Mon, Jan 7, 2019 at 8:16 PM Paolo Di Tommaso <[hidden email]> wrote:
Daer maintainers, 

The Nextflow joint build is failing with this error message.

System.getenv('CI_GROOVY_VERSION') == GroovySystem.getVersion()
       |                           |               |
       2.5.6-SNAPSHOT              |               2.5.5
                                   false
                                   10 differences (28% similarity)
                                   2.5.(6-SNAPSHOT)
                                   2.5.(5---------)


It looks the Groovy runtime version is not matching the declared version by the `CI_GROOVY_VERSION` env var. 

Could you please give it a look. 


Cheers,
Paolo

Reply | Threaded
Open this post in threaded view
|

Re: Failing joint build

Paolo Di Tommaso
Hi guys, 

I'm renewing my plea to fix the Nextflow joint build. This would have helped to early detect and prevent bugs such as GROOVY-9115.


Thanks, Paolo


On Mon, Feb 4, 2019 at 3:36 PM Paolo Di Tommaso <[hidden email]> wrote:
I'm raising again this issue. No way to fix it?


p

On Fri, Jan 11, 2019 at 12:51 PM Paul King <[hidden email]> wrote:
I get 2.5.6-SNAPSHOT as the version when I use locally built snapshots. I presume it is something specific to the Nextflow build but haven't had time to check yet.

On Fri, Jan 11, 2019 at 6:25 PM Paolo Di Tommaso <[hidden email]> wrote:
Hi devs,

Sorry if I insist on this, it may be that version string has not been updated on the 2.5.6 snapshot and therefore it's failing? 


p

On Mon, Jan 7, 2019 at 8:16 PM Paolo Di Tommaso <[hidden email]> wrote:
Daer maintainers, 

The Nextflow joint build is failing with this error message.

System.getenv('CI_GROOVY_VERSION') == GroovySystem.getVersion()
       |                           |               |
       2.5.6-SNAPSHOT              |               2.5.5
                                   false
                                   10 differences (28% similarity)
                                   2.5.(6-SNAPSHOT)
                                   2.5.(5---------)


It looks the Groovy runtime version is not matching the declared version by the `CI_GROOVY_VERSION` env var. 

Could you please give it a look. 


Cheers,
Paolo

Reply | Threaded
Open this post in threaded view
|

Re: Failing joint build

paulk_asert
It looks like the gradle build needs some further work:

[00:44:08] : [:nf-commons:compileGroovy] 00:44:08.057 [DEBUG] [org.gradle.api.internal.tasks.compile.NormalizingGroovyCompiler] Java compiler arguments: -source 1.8 -target 1.8 -d /var/teamcity/buildagent-jdk8/work/1d76058f36ec5c31/modules/nf-commons/build/classes/groovy/main -g -sourcepath  -proc:none -XDuseUnsharedTable=true -classpath ...[other jars]...:/var/teamcity/.gradle/caches/modules-2/files-2.1/org.codehaus.groovy/groovy/2.5.6/6936e700f0fb1b50bac0698ada4347a769d40199/groovy-2.5.6.jar:...[other jars]... /var/teamcity/buildagent-jdk8/work/1d76058f36ec5c31/modules/nf-commons/src/main/nextflow/util/QuoteStringTokenizer.groovy /var/teamcity/buildagent-jdk8/work/1d76058f36ec5c31/modules/nf-commons/src/main/nextflow/util/CsvParser.groovy ...[other source files]...

In some places I can see the Groovy version being overridden by the CI_GROOVY_VERSION value of 2.5.8-SNAPSHOT:

[00:43:18] : [Step 1/1] 00:43:16.617 [QUIET] [system.out] >> Overriding org.codehaus.groovy:groovy:2.5.6 with version: 2.5.8-SNAPSHOT

But in other places it seems not the case.

Cheers, Paul.


On Sat, May 11, 2019 at 6:52 PM Paolo Di Tommaso <[hidden email]> wrote:
Hi guys, 

I'm renewing my plea to fix the Nextflow joint build. This would have helped to early detect and prevent bugs such as GROOVY-9115.


Thanks, Paolo


On Mon, Feb 4, 2019 at 3:36 PM Paolo Di Tommaso <[hidden email]> wrote:
I'm raising again this issue. No way to fix it?


p

On Fri, Jan 11, 2019 at 12:51 PM Paul King <[hidden email]> wrote:
I get 2.5.6-SNAPSHOT as the version when I use locally built snapshots. I presume it is something specific to the Nextflow build but haven't had time to check yet.

On Fri, Jan 11, 2019 at 6:25 PM Paolo Di Tommaso <[hidden email]> wrote:
Hi devs,

Sorry if I insist on this, it may be that version string has not been updated on the 2.5.6 snapshot and therefore it's failing? 


p

On Mon, Jan 7, 2019 at 8:16 PM Paolo Di Tommaso <[hidden email]> wrote:
Daer maintainers, 

The Nextflow joint build is failing with this error message.

System.getenv('CI_GROOVY_VERSION') == GroovySystem.getVersion()
       |                           |               |
       2.5.6-SNAPSHOT              |               2.5.5
                                   false
                                   10 differences (28% similarity)
                                   2.5.(6-SNAPSHOT)
                                   2.5.(5---------)


It looks the Groovy runtime version is not matching the declared version by the `CI_GROOVY_VERSION` env var. 

Could you please give it a look. 


Cheers,
Paolo

Reply | Threaded
Open this post in threaded view
|

Re: Failing joint build

paulk_asert
It seems repeatable locally.

On Sun, May 19, 2019 at 10:17 AM Paul King <[hidden email]> wrote:
It looks like the gradle build needs some further work:

[00:44:08] : [:nf-commons:compileGroovy] 00:44:08.057 [DEBUG] [org.gradle.api.internal.tasks.compile.NormalizingGroovyCompiler] Java compiler arguments: -source 1.8 -target 1.8 -d /var/teamcity/buildagent-jdk8/work/1d76058f36ec5c31/modules/nf-commons/build/classes/groovy/main -g -sourcepath  -proc:none -XDuseUnsharedTable=true -classpath ...[other jars]...:/var/teamcity/.gradle/caches/modules-2/files-2.1/org.codehaus.groovy/groovy/2.5.6/6936e700f0fb1b50bac0698ada4347a769d40199/groovy-2.5.6.jar:...[other jars]... /var/teamcity/buildagent-jdk8/work/1d76058f36ec5c31/modules/nf-commons/src/main/nextflow/util/QuoteStringTokenizer.groovy /var/teamcity/buildagent-jdk8/work/1d76058f36ec5c31/modules/nf-commons/src/main/nextflow/util/CsvParser.groovy ...[other source files]...

In some places I can see the Groovy version being overridden by the CI_GROOVY_VERSION value of 2.5.8-SNAPSHOT:

[00:43:18] : [Step 1/1] 00:43:16.617 [QUIET] [system.out] >> Overriding org.codehaus.groovy:groovy:2.5.6 with version: 2.5.8-SNAPSHOT

But in other places it seems not the case.

Cheers, Paul.


On Sat, May 11, 2019 at 6:52 PM Paolo Di Tommaso <[hidden email]> wrote:
Hi guys, 

I'm renewing my plea to fix the Nextflow joint build. This would have helped to early detect and prevent bugs such as GROOVY-9115.


Thanks, Paolo


On Mon, Feb 4, 2019 at 3:36 PM Paolo Di Tommaso <[hidden email]> wrote:
I'm raising again this issue. No way to fix it?


p

On Fri, Jan 11, 2019 at 12:51 PM Paul King <[hidden email]> wrote:
I get 2.5.6-SNAPSHOT as the version when I use locally built snapshots. I presume it is something specific to the Nextflow build but haven't had time to check yet.

On Fri, Jan 11, 2019 at 6:25 PM Paolo Di Tommaso <[hidden email]> wrote:
Hi devs,

Sorry if I insist on this, it may be that version string has not been updated on the 2.5.6 snapshot and therefore it's failing? 


p

On Mon, Jan 7, 2019 at 8:16 PM Paolo Di Tommaso <[hidden email]> wrote:
Daer maintainers, 

The Nextflow joint build is failing with this error message.

System.getenv('CI_GROOVY_VERSION') == GroovySystem.getVersion()
       |                           |               |
       2.5.6-SNAPSHOT              |               2.5.5
                                   false
                                   10 differences (28% similarity)
                                   2.5.(6-SNAPSHOT)
                                   2.5.(5---------)


It looks the Groovy runtime version is not matching the declared version by the `CI_GROOVY_VERSION` env var. 

Could you please give it a look. 


Cheers,
Paolo

Reply | Threaded
Open this post in threaded view
|

Re: Failing joint build

Paolo Di Tommaso
Damn! you are right. The deps overriding should have gone in `allprojects` block. 

Thanks for having spotted that and updated the building environment. 


Cheers,
Paolo


On Sun, May 19, 2019 at 2:42 AM Paul King <[hidden email]> wrote:
It seems repeatable locally.

On Sun, May 19, 2019 at 10:17 AM Paul King <[hidden email]> wrote:
It looks like the gradle build needs some further work:

[00:44:08] : [:nf-commons:compileGroovy] 00:44:08.057 [DEBUG] [org.gradle.api.internal.tasks.compile.NormalizingGroovyCompiler] Java compiler arguments: -source 1.8 -target 1.8 -d /var/teamcity/buildagent-jdk8/work/1d76058f36ec5c31/modules/nf-commons/build/classes/groovy/main -g -sourcepath  -proc:none -XDuseUnsharedTable=true -classpath ...[other jars]...:/var/teamcity/.gradle/caches/modules-2/files-2.1/org.codehaus.groovy/groovy/2.5.6/6936e700f0fb1b50bac0698ada4347a769d40199/groovy-2.5.6.jar:...[other jars]... /var/teamcity/buildagent-jdk8/work/1d76058f36ec5c31/modules/nf-commons/src/main/nextflow/util/QuoteStringTokenizer.groovy /var/teamcity/buildagent-jdk8/work/1d76058f36ec5c31/modules/nf-commons/src/main/nextflow/util/CsvParser.groovy ...[other source files]...

In some places I can see the Groovy version being overridden by the CI_GROOVY_VERSION value of 2.5.8-SNAPSHOT:

[00:43:18] : [Step 1/1] 00:43:16.617 [QUIET] [system.out] >> Overriding org.codehaus.groovy:groovy:2.5.6 with version: 2.5.8-SNAPSHOT

But in other places it seems not the case.

Cheers, Paul.


On Sat, May 11, 2019 at 6:52 PM Paolo Di Tommaso <[hidden email]> wrote:
Hi guys, 

I'm renewing my plea to fix the Nextflow joint build. This would have helped to early detect and prevent bugs such as GROOVY-9115.


Thanks, Paolo


On Mon, Feb 4, 2019 at 3:36 PM Paolo Di Tommaso <[hidden email]> wrote:
I'm raising again this issue. No way to fix it?


p

On Fri, Jan 11, 2019 at 12:51 PM Paul King <[hidden email]> wrote:
I get 2.5.6-SNAPSHOT as the version when I use locally built snapshots. I presume it is something specific to the Nextflow build but haven't had time to check yet.

On Fri, Jan 11, 2019 at 6:25 PM Paolo Di Tommaso <[hidden email]> wrote:
Hi devs,

Sorry if I insist on this, it may be that version string has not been updated on the 2.5.6 snapshot and therefore it's failing? 


p

On Mon, Jan 7, 2019 at 8:16 PM Paolo Di Tommaso <[hidden email]> wrote:
Daer maintainers, 

The Nextflow joint build is failing with this error message.

System.getenv('CI_GROOVY_VERSION') == GroovySystem.getVersion()
       |                           |               |
       2.5.6-SNAPSHOT              |               2.5.5
                                   false
                                   10 differences (28% similarity)
                                   2.5.(6-SNAPSHOT)
                                   2.5.(5---------)


It looks the Groovy runtime version is not matching the declared version by the `CI_GROOVY_VERSION` env var. 

Could you please give it a look. 


Cheers,
Paolo

Reply | Threaded
Open this post in threaded view
|

Re: Failing joint build

Paolo Di Tommaso
Just to confirm the build fixed, though some tests failing due to changes in the snapshot version. 

Is there any change related to identity and Comparable interface coming in Groovy 2.5.8?


Cheers,
Paolo


On Sun, May 19, 2019 at 10:19 AM Paolo Di Tommaso <[hidden email]> wrote:
Damn! you are right. The deps overriding should have gone in `allprojects` block. 

Thanks for having spotted that and updated the building environment. 


Cheers,
Paolo


On Sun, May 19, 2019 at 2:42 AM Paul King <[hidden email]> wrote:
It seems repeatable locally.

On Sun, May 19, 2019 at 10:17 AM Paul King <[hidden email]> wrote:
It looks like the gradle build needs some further work:

[00:44:08] : [:nf-commons:compileGroovy] 00:44:08.057 [DEBUG] [org.gradle.api.internal.tasks.compile.NormalizingGroovyCompiler] Java compiler arguments: -source 1.8 -target 1.8 -d /var/teamcity/buildagent-jdk8/work/1d76058f36ec5c31/modules/nf-commons/build/classes/groovy/main -g -sourcepath  -proc:none -XDuseUnsharedTable=true -classpath ...[other jars]...:/var/teamcity/.gradle/caches/modules-2/files-2.1/org.codehaus.groovy/groovy/2.5.6/6936e700f0fb1b50bac0698ada4347a769d40199/groovy-2.5.6.jar:...[other jars]... /var/teamcity/buildagent-jdk8/work/1d76058f36ec5c31/modules/nf-commons/src/main/nextflow/util/QuoteStringTokenizer.groovy /var/teamcity/buildagent-jdk8/work/1d76058f36ec5c31/modules/nf-commons/src/main/nextflow/util/CsvParser.groovy ...[other source files]...

In some places I can see the Groovy version being overridden by the CI_GROOVY_VERSION value of 2.5.8-SNAPSHOT:

[00:43:18] : [Step 1/1] 00:43:16.617 [QUIET] [system.out] >> Overriding org.codehaus.groovy:groovy:2.5.6 with version: 2.5.8-SNAPSHOT

But in other places it seems not the case.

Cheers, Paul.


On Sat, May 11, 2019 at 6:52 PM Paolo Di Tommaso <[hidden email]> wrote:
Hi guys, 

I'm renewing my plea to fix the Nextflow joint build. This would have helped to early detect and prevent bugs such as GROOVY-9115.


Thanks, Paolo


On Mon, Feb 4, 2019 at 3:36 PM Paolo Di Tommaso <[hidden email]> wrote:
I'm raising again this issue. No way to fix it?


p

On Fri, Jan 11, 2019 at 12:51 PM Paul King <[hidden email]> wrote:
I get 2.5.6-SNAPSHOT as the version when I use locally built snapshots. I presume it is something specific to the Nextflow build but haven't had time to check yet.

On Fri, Jan 11, 2019 at 6:25 PM Paolo Di Tommaso <[hidden email]> wrote:
Hi devs,

Sorry if I insist on this, it may be that version string has not been updated on the 2.5.6 snapshot and therefore it's failing? 


p

On Mon, Jan 7, 2019 at 8:16 PM Paolo Di Tommaso <[hidden email]> wrote:
Daer maintainers, 

The Nextflow joint build is failing with this error message.

System.getenv('CI_GROOVY_VERSION') == GroovySystem.getVersion()
       |                           |               |
       2.5.6-SNAPSHOT              |               2.5.5
                                   false
                                   10 differences (28% similarity)
                                   2.5.(6-SNAPSHOT)
                                   2.5.(5---------)


It looks the Groovy runtime version is not matching the declared version by the `CI_GROOVY_VERSION` env var. 

Could you please give it a look. 


Cheers,
Paolo

Reply | Threaded
Open this post in threaded view
|

Re: Failing joint build

paulk_asert

Virus-free. www.avast.com

On Mon, May 20, 2019 at 3:30 PM Paolo Di Tommaso <[hidden email]> wrote:
Just to confirm the build fixed, though some tests failing due to changes in the snapshot version. 

Is there any change related to identity and Comparable interface coming in Groovy 2.5.8?


Cheers,
Paolo


On Sun, May 19, 2019 at 10:19 AM Paolo Di Tommaso <[hidden email]> wrote:
Damn! you are right. The deps overriding should have gone in `allprojects` block. 

Thanks for having spotted that and updated the building environment. 


Cheers,
Paolo


On Sun, May 19, 2019 at 2:42 AM Paul King <[hidden email]> wrote:
It seems repeatable locally.

On Sun, May 19, 2019 at 10:17 AM Paul King <[hidden email]> wrote:
It looks like the gradle build needs some further work:

[00:44:08] : [:nf-commons:compileGroovy] 00:44:08.057 [DEBUG] [org.gradle.api.internal.tasks.compile.NormalizingGroovyCompiler] Java compiler arguments: -source 1.8 -target 1.8 -d /var/teamcity/buildagent-jdk8/work/1d76058f36ec5c31/modules/nf-commons/build/classes/groovy/main -g -sourcepath  -proc:none -XDuseUnsharedTable=true -classpath ...[other jars]...:/var/teamcity/.gradle/caches/modules-2/files-2.1/org.codehaus.groovy/groovy/2.5.6/6936e700f0fb1b50bac0698ada4347a769d40199/groovy-2.5.6.jar:...[other jars]... /var/teamcity/buildagent-jdk8/work/1d76058f36ec5c31/modules/nf-commons/src/main/nextflow/util/QuoteStringTokenizer.groovy /var/teamcity/buildagent-jdk8/work/1d76058f36ec5c31/modules/nf-commons/src/main/nextflow/util/CsvParser.groovy ...[other source files]...

In some places I can see the Groovy version being overridden by the CI_GROOVY_VERSION value of 2.5.8-SNAPSHOT:

[00:43:18] : [Step 1/1] 00:43:16.617 [QUIET] [system.out] >> Overriding org.codehaus.groovy:groovy:2.5.6 with version: 2.5.8-SNAPSHOT

But in other places it seems not the case.

Cheers, Paul.


On Sat, May 11, 2019 at 6:52 PM Paolo Di Tommaso <[hidden email]> wrote:
Hi guys, 

I'm renewing my plea to fix the Nextflow joint build. This would have helped to early detect and prevent bugs such as GROOVY-9115.


Thanks, Paolo


On Mon, Feb 4, 2019 at 3:36 PM Paolo Di Tommaso <[hidden email]> wrote:
I'm raising again this issue. No way to fix it?


p

On Fri, Jan 11, 2019 at 12:51 PM Paul King <[hidden email]> wrote:
I get 2.5.6-SNAPSHOT as the version when I use locally built snapshots. I presume it is something specific to the Nextflow build but haven't had time to check yet.

On Fri, Jan 11, 2019 at 6:25 PM Paolo Di Tommaso <[hidden email]> wrote:
Hi devs,

Sorry if I insist on this, it may be that version string has not been updated on the 2.5.6 snapshot and therefore it's failing? 


p

On Mon, Jan 7, 2019 at 8:16 PM Paolo Di Tommaso <[hidden email]> wrote:
Daer maintainers, 

The Nextflow joint build is failing with this error message.

System.getenv('CI_GROOVY_VERSION') == GroovySystem.getVersion()
       |                           |               |
       2.5.6-SNAPSHOT              |               2.5.5
                                   false
                                   10 differences (28% similarity)
                                   2.5.(6-SNAPSHOT)
                                   2.5.(5---------)


It looks the Groovy runtime version is not matching the declared version by the `CI_GROOVY_VERSION` env var. 

Could you please give it a look. 


Cheers,
Paolo


Virus-free. www.avast.com
12